Can’t sync Philips Hue Hub and Bulbs


(Paul) #1

Been a ST user for a couple of years. I have all kinds of things connected around my house (bulbs, switches, motion sensors, thermostats, etc). Aside from an occasional glitch it all integrates great.

Until now, that is. I just bought a hue starter kit with 2 color bulbs that I just can’t seem to get integrated. I emailed support but have not gotten a response yet.

The Hue is set up and functioning in its native app with no issues. SmartThings is also working just fine. I can’t seem to get the two of them connected though. I add a thing through ST and get the “press the button on the hue bridge” pop up, but it just continuously clicks from there no matter how much time I give it. Both hue and ST are plugged into the same network switch and the lights are on when I try it.

Anybody else experience anything like this and find a solution?

Sorry if this is posted in the wrong place. Thank you for any help.


(jkp) #2

First, see if the hue bridge appears in your Things list. If it is there, then be patient and the lights will eventually show up. There have been many users seeing their lights finally show up hours later. :slight_smile:

If the hue bridge does not appear in the Things list, try assigning a static ip# to that device. Also, reboot your router, st hub and hue bridge.


(Paul) #3

Thank you for the response. The Hue Bridge does not appear as a thing. I will assign a static IP address tonight when I get home and reboot all. I’ll let you know if it works!

Thanks again.


(Kraeg) #4

Have you added the hub into the app from the market place?


(Paul) #5

Thanks for your response. I did try to add in the bulbs through the marketplace. I don’t believe there is a way to add the hub in through the marketplace any more (of course I could be wrong). I can go in and choose the bulb type in the marketplace and try to add them that way. I get a brief “press the button on the Hue Hub now” (or something similar) but nothing ever happens (no matter how long I wait).


(Kraeg) #6

Ah it’s been that long since I did it, I take it you’ve tried everything on the Support page: https://support.smartthings.com/hc/en-gb/articles/200848024-How-to-connect-Philips-hue-devices


(Paul) #7

Thanks again for the responses. No luck yet. The hub also integrated with the Alexa app with no problem and I’m able to automate from there. There must be something goofy that I’m missing with SmartThings.

I am using Google Wifi which is a mesh network, but I have the main hub tied directly to a switch that both Hue and ST are connected to. I tried removing the other network points and it still didn’t work.

I tried adding the Hue Hub through IDE under “add device” with its static IP address. The next time I went into the mobile app and tried to add a bulb it actually found the Hue hub and added it to the list of things, but ST is still unable to find any bulbs (endless waiting loop with an occasional “please push the button on the Hue bridge” command).

Any help would be greatly appreciated!


(jkp) #8

Check what the zigbee channels are set to on the ST hub and hue bridge. If they overlap, change the channel on the hue bridge.