Trouble connecting Hue Bridge to ST

Just got my Hue Bridge and a few Hue lights today.
My bridge finds all lights. Alexa finds my bridge and its lights. ST doesnt find anything.

If I remove all lights from the bridge, they are discovered in ST. But then I cannot connect them to the bridge.

I have tried:

  • Changing channel on Hue Bridge
  • Power cycle of everything; router, ST and Hue Bridge
  • Powering down bridge, enter “add a thing” in ST, powering up bridge.
  • Connecting the bridge directly to my main Deco mesh-device (and powering down all others)

I have checked:

  • That my bridge has the latest firmware
  • That I don`t have UPNP enabled

And I have been trough every forum post I could find.

The only reason I need ST to discover my bridge and lights is so I can use them with WebCore.

Any suggestions would be greatly appreciated!

For some users, adding the hue bridge can be a major frustration. Some additional items to try but with no guarantee they will resolve the issue:

Assign a static ip# to the hue bridge
Reboot the ST hub
Ensure the ST hub and hue bridge are both on the same network switch

1 Like

What an incredible mistake! :see_no_evil:
I had my ST on a different network!

But…both are on same network now.
Whats new is that I am told to press the button on the bridge. When I do, nothing happens.
I have tried pressing a couple of seconds before adding in ST, and powering down the bridge, and up again.

Any new suggestions would again be appreciated :slight_smile:

Check your Things list (Classic app) or Devices tab in the STSC app to ensure they were not added :slight_smile:

They were not added, no.

wait a few hours to see if things sync up. some users have mentioned that for them, devices will show up when they checked later. so patience in this case may be a virtue.

if they do not show up by tomorrow, open a ticket with ST support at

Thanks, will try this!

Status update.
Yesterday when I discovered that my ST and HB was on different networks, I moved my ST over to my standard mesh-network. I then got the message “press HB button”, but nothing happened.

I was in contact with ST support, which told me that mesh-networks often caused trouble (actually they told me its not possible to use). I then moved both ST and HB over to my ISP-modem, which works as a router, but only trough ethernet / cabeling. But it was the same thing, I was told to press HB button, but nothing happended when I did so. Support ran som diagnostics, and saw that there was som mac-adress conflict. She told me that this could resolve itself within 36-72 hours, I was just to retry.

But since non of this is connected to my WiFi, I didn`t have any way to control the Hue lights in the kids bedroom. I am still awaiting the remotes, only able to control via mobile ATM. I then connected everything back to my mesh-network.

And by doing this, I am now not getting the “press HB button” message. Probably the mesh-network messing it up.

My next question, which probably should be in a new thread: Is there any other way to integrate Hue lights in my routines? Some custom smartapp or webcore? I don`t want to connect the Hue Lights directly to ST.