Trouble Adding Bali Springs Winidow Fashions Window Treatment

I’m having an issue adding z-wave window treatments, curious if anyone has seen this issue before.

I have a number of Graber shades with the virtual cord z-wave control. I was able to add about 20 of them, using the Bali Springs Window Fashions device type. After that though, I was all of a sudden unable to add any more shades. I have about 100 devices associated with the hub, so I haven’t reached any sort of max.

I have about 10 or so shades left and have tried a number of them with the same (unsuccessful) result. In addition, I excluded and removed a shade I had added previously and I am not able to re-add it.

I have done a z-wave repair and restarted my hub multiple times with no success.

I have a ticket open with Samsung (their help desk has walk through the exclusion and re-add process with me a couple times with no success). However this ticket has been open for many weeks, and despite calling them multiple times a week I am gaining no traction. They originally suggested it was the z-wave module in the shade, but seeing as how I am having this problem with multiple shades, as well as one I had originally added and then excluded, I do not agree with this diagnosis.

Has anyone seen this behavior either with these types of shades, or with a different z-wave device type? Any suggestions as to how to resolve it? I suspect either the hub or the device driver is in a weird state. I should also note that I have been able to add other z-wave devices since I experienced this issue, just not the shades.

I’m getting a little frustrated with the lack of progress. I feel like without assistance my next step is to factory reset my hub and try to add everything again. I have a lot of devices however so this is not an appealing proposition.


If you are using a custom device handler and haven’t added any devices using that device handler in awhile, they may have become stale. To resolve, login to IDE, open the device handlers and Publish for Me. Then exclude the devices you tried to add and then attempt to pair them.

That is one thing to try, may or may not resolve your issue :slight_smile:

There is a known issue where device handlers can become stale preventing new devices from being paired.