Tp-Link HS105 not showing up in Smartthings

Added a TP-Link switch HS105 to Kasa and it works just like all the other devices. Also shows in the Deco app with a valid IP etc.

For whatever reason though, I cannot get that device to show up in Smartthings. When trying to add a TP-Link/Kasa device in Smartthings, it just shows me that it is connected and the outdated list of devices with the new one missing. No option to re-scan, nada…

Any ideas?

You can ignore the topic. It just took over 30 minutes!! to update the Smartthings device list (pretty pathetic actually) with the Kasa information.

There should at least be a manual scan trigger option somewhere, if Samsung cannot provide more reasonable update times.:anguished:

It’s not Samsung SmartThings, it’s TP Link. They have a 30 minute update cycle. You should write to them if you want to see it happen more quickly, there’s nothing smartthings can do about it. :disappointed_relieved:

More discussion in the following thread:

TP Link Kasa Devices with new official integration (July 2019): reviews needed

2 Likes

Ha - very interesting, never would have thought that it was a push and not a pull update. Thanks for the info - will for sure reach out to TP-Link.

I keep reading this issue and don’t understand.

I have a TP-Link HS105 and it showed up immediately when I added it, and any change of state for it also is immediate.

Problem was that I added the device to Kasa, was able to control it etc. and when trying to set up an automation in Smartthings, all devices showed up, besides the new one. Smartthings and Kasa are linked, so I expected the update to be real time/close to real time - but it took about 30 minutes for Smartthings and Kasa to sync. After that, the device showed up in Smartthings and all is good. Not so good was the time wasted troubleshooting a pathetic synchronization protocol’s timing problem :slight_smile:

That’s the unwritten tradeoff for using “Cloud-to-Cloud” connected devices that are not paying for “Works With SmartThings” Certification.

TP-Link (and many other WiFi devices) are considered “Compatible” (but not “Certified”). That means they don’t have to provide an optimal Device Type Handler; heck, it can be an incredibly buggy DTH.

SmartThings is, perhaps wisely, letting vendors get on the platform more quickly by staying out of their way.

You chose to buy a “cheaper” (I presume), non-SmartThings certified brand of device. It’s definitely TP-Link who deserves the complaint, not SmartThings.

1 Like

To be fair, I don’t think there’s any easy way for a consumer to tell the difference right now. They don’t show the logos in different categories when you check the app to see if a device is compatible. They’re just listed alphabetically.

1 Like

Well, the “leading device” here was actually the mesh router that had the “smart” capability built in. Then a few hubs were added and overall, I cannot complain a lot about how good/bad it works. This was the first time that I ran into an issue like this… oh well, hopefully at some point in the future, things will be more standardized and more companies follow that standard.

1 Like

The Kasa integration doesn’t currently support callbacks which is likely the cause of the delay. I would expect that would be added in the future.

However, it is my understanding that you should be able to force a ‘refresh’ by tapping on “TP-LINK | Kasa Smart” under “Connected services” in the app.

Problem is that there is no menu point anywhere like that :slight_smile:

I’m not sure what you mean by “no menu point”.

I think Brad is referring to, from the home screen in the new app:
Upper left hamburger menu > gear icon (settings) > connected services

2 Likes