Time based events failing?

I’m glad to see everyone’s events slowly coming back.

My sunrise/sunset lighting events appear to be working at the moment. This involved no input or changes from me (i.e. uninstalling/reinstalling apps).

However, coming and going and triggering routines based on time of day continue to fail.

And the big kicker today- my Smart Home Monitor is completely wonky. I had to manually change my status. When I change my status to disarm, I continually get alarms when doors are opened! :anguished:

So, even though it says disarmed, I still have to dismiss the intrusion alerts which shouldn’t even exist. Also, the interface for the Monitor is super slow and unresponsive.

It seems like when one thing starts working, two others go wrong. At this point, I still mostly rely on manually changing settings. I think it would be easier to use traditional light bulbs and switches and maybe put bells on my door to alert me to trouble. Gah!

I will try to rebuild my apps again to see if this resolves things and report back!

Mine have been working for about 3 days. It only didn’t fire once, but I was changing a receptacle, so power was off to the hub and internet. So much for local control.

Ben, do you acknowledge the users who want their things page back? If so do you intend to accommodate us at all?
I have asked this before and even messaged some ST staff over this but the only response anyone’s bothered to make is that there were no current plans to do anything about it.

Good grief! The design has moved on, and the things page has evolved. How is it reasonable to think ST should go backwards, when they are moving forward? If you want to see lots of things at a glance, get SmartTiles. I think they have told you the truth: it isn’t going to happen. Time to move on…

4 Likes

Is your name Ben?
I’ll answer you anyway.

Bringing back a handy feature that was already well established doesn’t seem like it would be a step backward.

Even if it was, the last couple of months of have seemed to be nothing but one step forward and two steps backward. How much difference would one more make?

Guys, let’s keep this thread restricted to Events related issues. I think there is already a missing dashboard related thread.

4 Likes

Another mode failure today… Home failed to trigger yesterday from Away when my wife arrived home. This time though, the “usual fix” did not resolve it. That is, last night I removed all references to Home in Routines and smartapps, then deleted and recreated Home and the routines that referenced it. Finally, I restored the smartapps to use Home again. This is the same thing I did yesterday after noticing that it failed to switch to Away after the last person left. This time though, no-go; system failed to switch from Night to Home this morning. It did switch from Night to Away when the last person left though.

Presence sensing is working, and other actions defined in the same routines that are calling Home are working. I don’t know what else to try. Opened another ticket .

ya I had by goodbye routine today fail to close the garage door. Running it manually a few minutes later worked fine?
go figure. It sucks to have to double check everything the hub is doing…

I also posted this thread related to sched. events failing… anyone have any ideas…

I forgot to mention one other thing (but not in my Support email), and it may be a clue to what’s causing modes to fail. When I noticed that the mode failed to switch, I checked Simple Rules Engine (SRE) and to my surprise, it shows the correct mode, and continues to! SRE is a 3rd-party oAuth app, so it’s almost as though ST actually is switching mode and sending status, but failing to act upon it itself.

Bob, for me when modes change via routines, the actions do happen but the app shows the stale status mostly (Night to home is always incorrect in the mornings) till I kill and reopen the app. But you are saying that actions fail for you as well. Right?

Yes and no. I noticed the non-realtime mode status long ago, and always close the app and re-open when in doubt. Other actions that are part of the same routine as the mode change work. Actions that are dependent on the mode change do not work.

I may have fixed the mode issue, at least for now. Here it is, for anyone suffering a similar issue and wants to give it a try.

  1. Delete Routines that use the failing mode
  2. Remove the failing mode(s) in all smartapps that use it
  3. Delete the mode
  4. Put everything back in reverse order

This is almost identical to the procedure I described above, except this time i did not restore the settings in Routines before moving on to the other steps. YMMV.

I offer this only as a datapoint: My apps that are dependent on mode changes all work fine, pretty much all of the time. My mode changes, triggered from “automatically perform” in a Routine, sometimes fail to happen. I’m ignoring the mobile app issue where it doesn’t display the actual mode without being killed first. Once or twice I’ve redone the Routine, by redoing the mode selection in it and redoing the automatically perform portion of the Routine. That’s all it’s ever taken for me to get a Routine caused mode change that failed, to get working again.

1 Like

I’m definitely not a smartthings expert and I’m sure that most everyone reading this knows more about smartthings than I do. I read through the last 250 posts and I didn’t see anyone suggest what fixed my problem, so I thought I would post it.

A few weeks ago I started noticing my time based and sunrise/sunset events had stopped working. I tried going into each smartapp and hello home command, making a small change, and hitting done. That didn’t seem to work for me.

Then I decided to try my usual fix for electronic items. I unplugged my V1 hub and any smartthings device that was controlled by time or sunset/sunrise. Then I shut off the circuit breakers in my electrical panel that fed all of my zwave light switches and outlets. I left everything off for an hour and then I plugged the hub and devices back in and turned the circuit breakers back on.

That was a week ago and I’m happy to say I haven’t had one failure since then and I’m once again happy with Smartthings. Maybe it was just dumb luck but I thought I would mention it.

1 Like

I know this is going to jinx it, but every scheduled event and trigger worked the last two days. Modes changed correctly and lights turned on and off as indicated. I have not made changes to the smart apps in about 3 days.

My only remaining issues is that the app has gotten ridiculously slow and the Smart Home Monitor sometimes doesn’t recognize manual changes to the armed status. Again, I think this is because the app is being outrageously slow to respond to taps and requests. I’m on iOS and it appears to be a server side issue. I’ve tried requests on differs networks.

Anyone still having issues or are things clearing up?

I thought this was solved, but I created two time based instances of the Smart Lighting App to turn on and off newly installed switches (installed today, one low light overhead lamp late at night, one brighter one during the awake hours) and neither of them worked. As soon as I took off the time restriction, they worked no problem. Is there still an issue?

Yeah, I’m having major slow downs as well. As well as other issues, which I just posted about.

No issues anymore, this is fixed for me.

My system was very stable regarding time based routines but today my good morning failed to fire. Then my fiancés phone kept showing her arriving at home even though she was with me. Crazy b

Those might be two separate issues. Re the first one, see my post above for how I fixed my mode problem. I know it shouldn’t be necessary, but…

On the matter of the false presence sensing, check the “Minimum away time.” I found that values smaller than 2 minutes were unreliable and prone to false alarms.