This SmartApp can't be deleted at this time because it is installed by one or more users

Can someone advise me on this please.

Both my girlfriend and I have access to our SmartThings hub with our own accounts.

I installed an app (Nest Manager) via the IDE online, and configured it on my phone, however I had some issues with it and I need to delete it and reinstall it.

How am I supposed to do this, when everything something is added, it cannot be removed without going into every phone and removing it manually?
My girlfriend is not technical and she’s out of town. My heating is all out of sync now because it’s still running routines form her phone because it’s not installed on my phone.

Any suggestions?

1 Like

You can do this through the IDE:
IDE-> my locations -> list smart apps->edit->delete


This is where I am seeing the error. I tried to remove it in the app, does nothing, no error. In the IDE, i get the error above

1 Like

Please check again… Are you sure you follow the path in the IDE from my post above? This deletes the installed instance of an app.

The error message you are getting is normal if you try to delete an app in the “my smartapps” menu.


You said both if you have access through separate accounts? Did you have it installed and then send her an invite to join the account? Which is how it should have occurred.

Any changes made on your phone in the app reflect equally in her phone app. And vice versa.

Ensure you attempt to remove the app the way it was listed above by @pizzinini.

FYI, it is not normal to get that error when attempting to remove an app from the mobile app. It’s a bug in the system.

If you can not delete the app through the API, go into the app and remove all of the setting by tapping on each option and deleting them. Basically leaving the app empty.

Once you have done that, go back to the market place and run the install on the app again. Yes, this will probably give you two instances of the ago, but with all of the settings removed from one, the other should work. I’ve had to do this before.

Then, send an email to support asking them to remove the empty smart app from your system.

OK @pizzinini’s suggestion has worked. I wasn’t aware you could uninstall the app from the location screen. I was under the impression that Deleting the SmartApp did the same thing.

Problem solved :slight_smile:


Yep. Awesome!

1 Like

Can we add this to the FAQ section? This is a very helpful thread.

1 Like

The content of the error seems to be misleading. You say a user is already using it, but actually the issue is it is attached to location. So can you guys update your messaging to reflect the users mental model instead please.

This is actually an issue (good content) throughout the product. ST would be ‘smart’ to hire a digital content designer to help organise your content’s IA and words on the screen.

1 Like

I agree. Many companies either hire incompetent UI designers or none at all. In the latter, us engineers are thrust into the UI world. It’s like trying to breathe underwater without any life support.

You can also have “Over UI designed” apps that forsake functionality for flash and dazzle.

Case-and-point. Try out the new Subway app (Subway sandwich shops). Beautiful, but basically non-functional.

Sorry for the slightly off-topic rant.

My current subway app is just a QR code and points balance - i seldom use the other features. And it works great. I think I won’t update when asked now.

It is all a segue from the specific point, but I will setup a separate post to discuss.

Old thread but I was facing this and finally found a workaround. My issue stemmed from using the simulator, which kept on going unresponsive and the net was that I had like 15-20 orphaned Smart Apps that would not delete. I tried deleting them from the Smart App’s App Settings page and was getting the “installed by one or more users” error. I tried from the mobile app and got some sort of general error. And I tried the method by going through the My Locations --> Home -> List Smart Apps and doing the Uninstall but that didn’t work and gave “There was an error uninstalling your SmartApp.”

The cause of this seems related to my use of the dreaded Simulator. Basically I think the virtual devices used were somehow locking the app and preventing deletion. And of course it was the Simulator that caused me to create a bunch of additional copies since it would stop functioning so I should have probably thought about this earlier.

What ended up working was to go back into the undesired Smart App instance code and re-open the Simulator tab and then select any PHYSICAL device / sensor /etc. instead of one of the simulated ones. Afterwards, click the Uninstall button in the Simulator (probably no need to Install it after changing the devices but I did have a couple that seemed to take forever and the Install seemed to fix that). Afterwards, you can then go into the App Settings and delete it successfully.

A lot of steps but after waiting 36 hours+ for ST Support to respond to my request to have them delete the apps this was better.

I’m having the same set of issues, I was able to delete the child apps but not NST-Manager itself. I hadn’t used the simulator for this App, so that approach didn’t work. Is there a way to force delete this?

You can ask Support to do it for you if you can’t get it. Expect up to 48 hours for help, often sooner.

I have tried everything to delete this stupid smartapps and nothing works. Not even this.

Which smartapp are you attempting to remove? It is possible if that app created any devices in ST, that you would need to remove those devices before you can remove the app.

Ecobee connect. I just got it. I went through and deleted a bunch of smartapps and then tried that one again and success. Some how they must have been tied together.

1 Like

Holy mother of thread resurrection batman.

I’ve had the same problem and no matter what I do I am not able to update from 4.5.2 to the latest version of the Nest Manager plugin. It was probably originally installed by pasting code (I’m in the UK), but more recently I have the Github integration working with other plugins.

I’ve installed the ST-Community-Installer and used it do deploy HomeBridge-v2. I wanted to use it to upgrade Nest Manager, but it when I run the install, it says it has installed it but the version doesn’t change.

I’ve tried deleting the Nest Manager from the app (it pops up the error at the top about installed by other user). I’ve tried deleting it on the SmartThings Locations (I got this to work, but when I go back into the app it is still there at the old version). I’ve tried uninstalling and reinstallng the app (it’s still there). This is a massive pain because I cannot update it.

FYI… by removing the NST Manager smartapp, you will lose the Nest integration and there is no way to restore it.

Thanks. Somehow I’ve managed to update the code in the IDE from Github and now it has updated to the latest 5.x release. Phew.

However, it asks me to login to in the app and when it shows me the permissions it needs and click Allow, it shows shows a red banner at the top of the screen ‘Ooops! We’ve encountered an error. Please try again.’