SmartThings Community

Problems trying to remove smartapp


(Gene Clark) #1

There’s a smartapp that was installed and can’t for the life of me uninstall it. I’ve tried removing it in the My Apps section of the iOS app which does absolutely nothing from what it looks like; as well tried deleting the file in the smartapps section of the IDE, but get the following error message every time…

“This SmartApp can’t be deleted at this time because it is installed by one or more users”

Any suggestions?


(jkp) #2

Try in IDE under My locations: smartapps: click edit, then uninstall for the smartapp in question :slight_smile:


(Gene Clark) #3

Thank you very much! That worked like a charm!


(Andy Edgeworth) #4

Just hit the same problem myself. Worked for me too, so thanks very much.


(Matt Edwards) #5

Hi all. not working for me at all.
On the IDE / My SmartApps DELETE - I get the one or more users error.
ON the IDE / My Locations / List SmartApps / Edit / Uninstall - I get "There was an error uninstalling your SmartApp."
in the APP (iOS) - SmartApps Tab / Click APP / Remove / Are you Sure? / Remove - I get “An unexpected error occurred”.
Anywhere else?
Cheers, MM


(jkp) #6

what app are you trying to remove?


(Arn B) #7

Make sure it is uninstalled in phone app. Then in Ide click on simulator tap/ set location tap uninstall a few times, go back to apps page clear usage on right side of page then try to delete again


(Matt Edwards) #8

Thanks for the help, but as i said, i cant delete it in the iOS app, i get “Unexpected Error”.
The app i am trying to delete is Konnected Security, as i want to start again.


(jkp) #9

I would recommend contacting support at this point. They should be able to remove it on their end.

https://support.smartthings.com/hc/en-us


(Gene Clark) #10

I have one I can to delete from the iOS app either Logitech Harmony (Connect). I’ve just learned to live with it.


(Andy Edgeworth) #11

Had one App do this. Quick email to support. They fixed it in a couple of hours.