This device is unavailable at the moment

I have two devices that show a message that says “this device is unavailable at the moment” when I select them from the Things screen. There is a link on the screen that says “Explore help topics to solve this issue.” The words “help topic” are blue, indicating a link to a help topic. Clicking the words “help topic” does absolutely nothing. Does anyone know how I get the devices to become available again?

I searched the support site for “this device is unavailable at the moment” and get 107 hits, none of which address the issue. I also see someone asked the exact same question and there was no response.

Any help is appreciated. Also, if anyone else sees the same message, does the help topic “link” take you to a help topic or is that a problem with my phone?

1 Like

There’s been some discussion about the new health check “feature” letting you know about devices that have gone offline. Depending on what the device is, the easiest fix is to remove the battery for about 15 seconds and then replace it. By doing so, hopefully the device will wake up and reconnect again. Sometimes you have to do a full reset and re-pair it to the hub. Although one member did comment that the app just hasn’t updated the status and by somehow interacting with it will bring it back. As far as the help topic link goes, it doesn’t work for me either.

1 Like

Strange that you post this today, because I’m also having this issue and it’s only occurred since around 7pm PDT.

Both of my ecobee3 lites were showing unavailable. I used the app and accessed them immediately, so it didn’t appear to be the devices. I cleared the error by clicking the X on the top right of the error, then clicking the red refresh on the device tile.

However, it occurred again around 1/2 hour ago. Could this be a bigger st issue?

There seem to have been more posts about things going off-line this past week. I haven’t really seen any commonality in the posts I have read beyond the fact that things dropped off the network.

I had a z-wave switch drop off the network this week myself. That’s only the 2nd time I have ever had that happen. Timing seems very coincidental considering all the others having similar problems lately.

I’ve got about 5 or 6 devices that have said this since the last update. Removed on and tried to find it with no luck. Trying the battery reset now.

I had a problem yesterday where about a half dozen devices showed not available. This prevented me from testing the devices until I turned off the device health option. Once that was done I was able to control those devices again. For some reason smartthings thought those devices were broken but in actuality they weren’t.

When the new Device Health feature in my iOS app is enabled, I have a few devices that show “unavailable” sporadically. If I go into the device and click “ok” to the message they come back to normal state. They appear to work fine with my automations and this appears to be a cosmetic bug where they actually still functional. For now, I have turned off device health.

I’ve been getting devices going offline for the past few days now. I changed a few batteries and still the device say unavailable. I tried to do a repair, but that hasn’t helped either. Even when a device is working, the response time is EXTREAMLY slow. No network changes or internet changes, so all should be good there, it just seems that the sensors are not reporting a change as quickly as they once did. I haven’t received the latest update yet, as I am still on 16.14.

WAF is rapidly falling.

So today I got some more CR2450 batteries. I tried changing the batteries again on the device that where unavailable. After changing the batteries on the 2 motion sensors that have gone unavailable the most, everything else came back online. Of the 5 devise, I only changed 2 batteries and it seems like things are working. Looks like the batteries where just too weak, even though ST reported them as being 79%

I had one SmartThings Multi go off-line this morning too. I removed and put the battery right back in. No luck. Like you, I then changed the CR2450 battery in it - in spite of the fact that ST had said it was at 67% just before it went offline… It came right back up and is running well again.

I got a little upset when I first saw a “device unavailable” message. Then I remembered that two of my smart plugs are themselves on switched circuits, and those were the ones showing the error. So from my standpoint, the feature is working correctly.

Happening to me again even on devices that I just changed the battery on. Tried reseating the battery on a couple and that worked. Two I just changed the battery on I can’t even reset the device. Device just keeps blinking blue.

I have lots of devices that keep showing up as “unavailable” in my mobile app however in 99.9% of the cases it was just a switch or dimmer I do not use often so I just click the X on the top right and then press the refresh button or simply turn it on/off. Interacting with the device makes it available again. It looks like the hub considers any quiet-for-too-long device to be offline which is quite annoying since it doesn’t really mean it is not working. Only in a couple cases I had to replace batteries as the sensor was actually dead. Right now this feature seems more of a bother than a benefit but I am hoping they will iron out these issues and make it useful.

Can someone from ST comment? @slagle?


Same here. Over the last few weeks, I’ve been getting more and more devices showing as unavailable. The only way to get them back has been to remove and add to the network. This included sensors, outlets, bulbs. I’ve had health check enabled since the feature became available. I guess I will try turning it off. I’ve only this issue once or twice in the last year before.

Can ST comment?

The “device unavailable” problem has become a daily occurrence. In some cases I can wake the device by triggering it (for example, I wet my finger and touch the contacts on my leak sensors). In other cases, I have to remove the battery for a few seconds (motion sensors). It’s apparent that SmartThings has some work to do in order to make this feature useful instead of just irritating as hell.

1 Like

I have been seeing this on an older GE wall switch. When the message showed up I could just close it and work the device just fine. I setup pollster to poll it every 5 minutes and haven’t had a problem since.

My thought was the device wasn’t self reporting so smartthings thought it was unavailable. So now with pollster, instead of it checking in smartthings reaches out to it and asks if it is ok. Which it is.

I don’t know if my logic is correct, but it seems to be working. Not a great solution for battery powered devices, but should be fine for mains.

1 Like

I too keep getting devices showing up as unavailable. In some cases all I need to do is trigger the device to turn on and turn off from the application and it appears to come back.

I do however have some devices that I have completely lost connection to and because they are wall switches I cannot simply remove a battery wait a while and put them back in as they are plugged directly to the electric system. The switches I am using are the Evolve LTM-15… Followed their guide to reset them but I have at least one device that it’s been a few weeks that I no longer have access to from the app.

I hope ST comes up with a solution to this

If your switches are Z-Wave you may need to perform a Z-Wave replace. I have had to do this twice for GE switches in my home. It has worked both times. Remember however, when pairing a device it must communicate directly with the hub. Pairing messages do not get repeated by nearby powered devices. You will need to bring the hub into close proximity to the switch.

I was having the unavailable issue on several devices but Alexa was able to turn them on/off so did the minimotes. I turned off Device Health and problem solved.

1 Like

I have had at least one, and up to 3 devices reporting as unavailable every day for the last two weeks. As others have reported, all these devices are actually functioning properly, it is only the app that reports them incorrectly.

I will also turn off Device Health and see if that makes a difference. Will report back. I presume that the entire “unavailable” state is a feature of the Device Health capability, so turning it off would eliminate that reporting state.