Thermostat problems (multiple brands) Nov 2022

I currently have Alarm.com.
Can I add the Ct100 thermostat to my alarm panel and be able to use it with Alarm.com or for it to work I need pay alarm provider?

Is this the way it is supose to look as far as face goes or this this outdated?

Any luck with your Centralite thermostat? I have the Edge driver version from 2-14 and it still doesn’t work properly.

Yeah, I’m on the 2-14 ZigBee thermostat edge driver too and checked to see if any of my heating temperature changes worked today, and I see one temperature change out of an expected 3 and it’s to a temperature that I don’t even have programmed in any routines (60 degrees) at a time that I wouldn’t have programmed a temperature change. I wonder if I had some smart lighting rule that doesn’t show up in the routines list?

Thankfully my house seems to be needing less heating lately, so it hasn’t gotten to the point where I feel the need to modify all routines to turn heating on and off instead of using a lower and higher set point.

Yeah, it’s frustrating. It worked perfectly for me prior to the Edge update. Now, it’s hit or miss (mostly miss) whether adjusting the temperature via any of these methods will work:

  • automation
  • Alexa command
  • manually through the app
1 Like

Was there every any resolution to this issue? I just recently noticed that my thermostats aren’t always reporting the current temperature accurately.

Other than a recent hub update, there have been no changes to the devices or driver in months. Most likely what did change was that the weather warmed up and I started paying attention, especially after a couple of my when some of my warm-weather HVAC automations failed.

The devices are online, and a Refresh command will update the data, but so far I haven’t been able to predict when the thermostat will stop reporting.

Mine is actually finally working properly from what I’ve seen, but I never noticed if it wasn’t reporting the temperature properly in SmartThings. I just checked now and the temp in ST matches the temp on the actual device, but of course that’s only one data point.

I have an automation that monitors each of the thermostat’s reported temperatures and notifies me when one of them hasn’t changed after a fixed period of time. At then point, I either look at the thermostat itself and compare it to what SmartThings is reporting or issue a Refresh command via the API and see if the temperature changes.

Happened again overnight last night. Be nice to know if someone, anyone, found a reliable resolution.

I have 2 CT100 thermostats, one is working fine, the other works but the thermostat state always shows idle even when the unit is cooling. Anyone else seeing this?

No, I don’t have this issue. I don’t even see an “Idle” mode for the thermostat in SmartThings. I see: Off, Heat, Auto, Cool, and Emergency. Do you have the latest Edge driver? Mine is “Zigbee Thermostat”, version 2023-08-15.

I have 4 pearl centrality thermostats that worked flawlessly with smarthings + Google home until they all disappeared 2 months ago from my system. Reset (17-11) them and they reconnected and all was good. As if three days ago they are all offline and SmartThings via iPhone cannot see them to re-add. Any ideas?

I have 2 Pearl Centralite Thermostats. I installed smartthings and the thermostats in 2014. They worked flawlessly with each hub as I upgraded the hub to V2 and changed drivers and IDE. However, about a month ago, I noticed I had to start manually turning the Thermostats up and down. Alexa would control them but the routines quit working. I have finally had time to look into the issue. One thermostat was recognized as a Centrallite Thermostats and the Zigbee Thermostat driver was installed. However, the other Thermostat was not recognized and the Zigbee Thing driver was installed. I deleted/removed that thermostat from the hub using the phone app. Now I cannot add it back. I have removed the thermostat from the network and re-added. performed a factory reset. Pulled the batteries. The Thermostat indicates it found the network and joined it. I scan for a new device with smartthings and cannot find the thermostat that was removed. The other thermostat is now working fine after deleting and recreating routines for it. But I need the other thermostat back in Smartthings.

Me and another user are having the same issue with Zigbee devices we removed from ST and now we can’t add them back anymore! Mine is a Zigbee motion sensor and his is as well. I’m wondering if it’s the same issue! I was able to add mine to another hub and remove it and add it back again without issue. It just wont pair to the original hub!

1 Like

Ecobee thermostat has become extremely unreliable in the last three or four days. Prior to this I’ve had no issues ever.