Iris IL07 motion detector no longer pairs to hub after 50.10 update

I have an issue with an Iris IL07 motion sensor that has worked flawlessly for the past 4 years. I had an issue with it after the update to 50.10. It went offline and I tried removing it and factory resetting it and pairing it again. Device shows it paired but scan nearby says no devices found and the device doesn’t show in any room or in the ST advanced webpage.

I have 3 V3 hubs in my smart home setup. Zigbee hub (original), Zwave hub (added last year) and integration hub (added last year) All 3 are at 50.10. All Zigbee device are on hub 1, all Zwave devices are on hub 2 and all third-party integrations and virtual devices are on hub 3. I have narrowed this problem down to hub 1, Zigbee. It seems to me that even though I removed the device from hub 1, its still in memory or something.
All hubs are hard coded to channel 25 and it has worked this way since day 1. I have 20 more of the same exact sensors working fine. I have never had any major Zigbee problems in the past. Plenty of Zigbee smart plugs and switches throughout the house.

Troubleshooting steps I have tried and narrowed it down to hub 1. All pairing and removing was done with the sensor sitting on top of the hub it was being paired to. I have tried both scan nearby and Iris and scan barcode.

  1. Unplugged hub 1 for 30 minutes and let Zigbee mesh rebuild. Tried adding it again and the device shows it paired by light sequence but still doesn’t show anywhere in ST.
  2. Factory reset device again and it pairs immediately with both hub 2 and 3 and works fine. But I can’t leave it this way because I have no other Zigbee devices paired with hub 2 or 3 and the place where I use this is a floor above the hub, so no Zigbee mesh on hub 2 or 3!
  3. Tried using Mariano’s Zigbee motion sensor driver instead of the ST Zigbee motion sensor driver. Still the same results.
  4. Tried leaving it paired to hub 2 for a day and then removing it and adding it back to hub1 and same results.

I can’t think of anything else to try. In the days before edge, I could have probably resolved this in the IDE!
The device must be stuck in memory someplace in hub1, I don’t want to reset hub 1 to resolve this as I have another 140 some odd Zigbee devices connected to it with multiple routines. This didn’t start happening until version 50.10! I’m thinking maybe I should buy a 4th V3 hub or Station and try hub replace to the new one and then keep the original Zigbee hub as a spare.

Thoughts anyone?

yes, do NOT reset the hub

I would recommend NOT doing this. What if Hub Replace transfers the issue to the new hub?

I would add Step 5 to your troubleshooting steps:
5. Contact ST support :slight_smile:

Give them access to your hub. attempt to add the device, provide the date/time that you attempted, do not restart or power cycle your hub after… and be patient while they investigate.

I you tried removing the battery in the sensor for say 30 min. before trying to pair? Probably won’t help, but easy enough to try.

I may try this, to be honest I have opened 4 or 5 different support cases over the years and they have not fixed a single one! I was able to figure them out myself reading the forums or Mariano helped me.

Removed the battery and let it sit for 3 days and still the same issue.

Hi @mlchelp

In the early days of edge, there were cases of devices that were uninstalled and for some reason remained paired to the driver and did not appear anywhere.

You could check it with the cli by seeing if you receive messages from that device.

I seem to remember that the solution was:

  • disable zigbee secure rejoint on the hub settings.
  • On the device, reset the device to put it in pairing mode. A lifecycle removed log could appear in the CLI, that would be great news.
  • In the app add a new device and check if there is activity in the CLI logs.

By repeating this several times in a row, it was either successfully uninstalled or re-paired with all the old information that the hub has about the device.

There has been another user who has had something similar happen to them with a Lidl motion sensor.
I don’t know if he has solved it

Thank you, I will see if the CLI helps.

I did see this post and I was also thinking that it may be the same issue that I’m having.

@lucien were you able to resolve the issue you were having with the Lidi motion sensor?

Tried logcat on Zigbee motion sensor and nothing logged when joining the device or factory resetting the device. I did notice that after the device blinks it’s LED green 3 times signifying it was paired and then remove the battery and put it back in, it starts blinking again that its in paring mode. So I’m now thinking it is not getting paired and I just thought it was because of the led sequence. I don’t believe its stuck in hub 1’s memory anymore. For some reason it just wont pair with the original hub anymore.

I’m going to try and remove some Zigbee devices and try pairing it again. I have 84 Zigbee devices paired to Hub 1. I don’t think that’s to many for my setup but I figured at least I can rule that out.

@mlchelp Hi Michael, I was not able to resolve the Lidl Motion Sensor. Issue remains after several attempts over 3 days. Each time I removed the battery and reset the sensor before pairing back to Aeotec Hub.

I have been working on this all day. These are the additional things I have done to try and resolve this issue.
5. Call support and open a ticket as suggested by Jkp. I haven’t done this yet but may be my next step. I wanted to get all of the nonsense stuff that support will have me do first.
6. Removed another Iris IL07 and tried adding it back and now this one no longer pairs to hub 1 either. Now I have 2 of the same exact devices that will no longer pair to the original hub after being removed and I can pair them and remove them to the other 2 hubs without issue.
7. Tried different drivers, Zigbee Motion Sensor and Zigbee Motion Sensor MC. Doesn’t work with either one.
8. Moved my hub and sensors into a room where there are no wireless access points and they still don’t pair.
9. Tried pairing from my tablet and also removing and reinstalling the ST ap.
To me now it seems that the pairing process starts and then the device shows it pairs by led sequence and then the hub never finishes the process. When I remove the battery from the device and replace it, then it shows its in pairing mode again.
Now I have 2 devices that wont work and I’m not going to try that again and end up with more!
3 posts I have seen so far that seem like the same issue.

@lucien @wmrath Are either of you seeing the same thing? Device seems like it pairs but ST says no devices found and when you remove the battery and replace it then the device goes back into pairing mode again?

EDIT Update Problem fixed!

This morning I took Jkp’s advice and called ST support. It was super easy to get connected to a support rep, wow how things have changed at Samsung since the last time I called them and the support rep actually new what I was talking about and was very knowledgeable! Not the old ST support anymore.

I gave the tech access to my account through the ST webpage he took a look and asked me to add the device again and send him a screen shot. The device immediately paired with hub 1 that didn’t work that I worked on all day yesterday! Tried the second sensor and it paired as well. Problem solved. He said he didn’t do anything or change any settings at all. Hmmm.

I’m now not sure how this was fixed but I’m happy it is working now. Maybe something I did yesterday or they fixed an issue with 50.10 over night or the tech did something and didn’t want to tell me.

@lucien @wmrath Try pairing those devices again and do report back if it works now and if not call support!

1 Like

Do your Iris IL07 report temperature?

Yes mine do.

Yes, mine report temperature, and they are using the stock Zigbee motion sensor driver.