There was a problem retrieving the livestream

Camera is constantly stuck on this? any offers of help/tips on this one?

Which camera are you using?

Sorry, should have said,
Smart cam HD pro

Mine has been the same. I deleted and now the autodiscover isn’t working to find it. I’ll be opening a support ticket soon.

I think I’ve got more support tickets than I know what to do with!!

Support was able to resolve for me. I don’t know what they did, but I was able to re-discover.

I had a similar issue. Did your camera work after re-adding it @chevyman142000?
Support told me there was a known issue and they were working on a fix. Maybe this Hub update in a few hours will be just the thing I need to get my SmartCams up and running again!

It did not play the first time I tried after re-adding it. I then force closed the SmartThings app, re-opened, and the video did work. I just tried now as I’m remote at work and it also worked.

1 Like

Good to know. Thanks for the reply. Have removed and readded two different cameras. Force closing the app multiple times (and/or rebooting the phone), and I still have issues viewing the stream. Did you update the cam firmware? I think it’s 1.0.7.

Yes, it is on the latest firmware.

I’m seeing same issue as I’ve just migrated from one V2 hub to a new one… anyone have any update on if the problem still exists for them? I’m using D-Link DCS5222, worked before on my old hub, but its been a few weeks since I’ve used the SmartThing app for camera usage… so not sure how long its been broke… could have pre-dated the hub change.

One of my two cameras is doing the same thing. Rebooted smartthings, iphone, etc… And still I cannot view that camera from the ST app. I can from DLink LIte app. So I know it works!!! Come on ST…help us out! Let us know what we need to do!

1 Like

Hey all, has this been resolved?
I am still getting the could not retrieve the livestream image. ST support is having me reboot all items and retry (force restarts etc.) But none of this seems to be working?


My Smartcam Pro has just started giving this livestream error.

It might be that the flash memory is running out on your hub. Get support to look at this. This was what happened to me…

Some bad news. I chatted with ST support this am and the problem is with recent firmware updates to the ST hub. I have two hubs in 2 physical locations on 2 different routers with 2 HD Pro cameras on each hub. All four cameras became inaccessible from within ST at about the same time. Removing and re-pairing the cameras did not help. The cameras are “active” and work fine in the SmartCam app but cannot be accessed from within the ST app. Worse yet, I can no longer have ST tell the cameras to record video on motion detection. Support says their “engineers are working on the problem,” so based on my experience, that means the problem is not going to be fixed (apparently “Engineer” is the name of the pet rabbit at ST support). So the options are: settle for stills instead of video, hope thieves don’t steal the camera along with the sd card (brilliant design there!), pay Samsung for cloud video, buy new cameras, or switch to a different hub.