Temperature sensor that updates temp often

I wanted to use a Samsung Smart Button for temperature because it’s pretty accurate (it’s pretty much the same as my ecobee sensors) and can do 0.1C increments but the problem is it updates every 5 min and I need it to update maybe every 1 min or when there’s a 0.5C change, so I get readings more often.

1.Is there any default/built in DTH for the Samsung Smart Button that will update more often or I can set how often it updates? (time or temp)

2.Is there a custom DTH for the Samsung Smart Button I can use if there’s not default/build in DTH to update more often?

3.Is there another brand temp sensor that has a default/built in DTH that will update more often?

4.Is there a custom DTH for another brand temp sensor that will update more often?

Ideally, I’d like to use something that uses a default/built in DTH to avoid the cloud. But if there’s nothing available then I could use a custom DTH if needed. I didn’t want to use the ecobee sensors because that would be relying on 2 clouds (ecobee and smarthings).


Just be aware that more frequent reporting means you will use up the battery much more quickly.


The answer is yes there’s a modified dth for the button so you can customise reporting, and it runs local too. Kudos to @Mariano_Colmenarejo

1 Like

Thanks for the heads up JDRoberts. I figured the battery would go quicker which is kind of why I like the idea of the Smart Button because it doesn’t have a bunch of other sensors in it to use up the battery. I’ll only be using Temp.

1 Like

Thanks Alwas. That’s exactly what I’m looking for, adjust it and have it run local.
The link you posted doesn’t work though.
I get a " Oops! That page doesn’t exist or is private." when I try to go to it.

I put the correct link up now and yes I think most people realise in this day and age that battery performance will be affected once you start playing with settings.

1 Like

Found the link! I search for Mariano_Colmenarejo posts and found it.
Just installed the DTH and trying them out now.

Thanks so much! And thank you @Mariano_Colmenarejo for taking the time to make the DTHs.

The button with the original DTH updates the temperature every 5 minutes and gives an accuracy of 0.1 °.
With this, the CR2450 battery of the open / close multisensor is empty in 2 months. I don’t know what battery use the button.
Motion sensors use the CR123A which has much more capacity.
the modification I made is for the opposite that you need, I think I understand.
It gives less precision by lengthening the maximum interval of the report between 5m and 120m, I have it in 60, In order to maximize the batteries.
It could be modified to be between 1 and 120min, but you will not get more precision because it allways rounds the temperature calculation to 0.1
The minimum time default is set at 30s.


Hi @Mariano_Colmenarejo

I was just about to ask you about it :slight_smile:

The button uses a CR2450. I’m not too concerned about battery life as I have lots of CR2450.
I’m more concerned about responsiveness. I’m not sure of the exact values I need for my smart vent, have to do some testing.

1.I found in the DTH where the range said 5…120 and I changed it to 1…120.
Is that all I need to change to have it update every 1min?

2.Does it only update every 1 min when temp changes by X degrees?
(So do I need both settings filled in?)

3.The temp offset doesn’t allow me to put in 0.1C, I can only put in 1C. If I put in 1 is that 0.1? Or is it 1?
I’m not sure if there’s math being done in the DTH that divides the 1 by 10 for finer accuracy (only because it says -100 to 100, I’d assume a 100 change is a bit much :slight_smile:

Thanks again for the DTH!

Just be aware that for longer battery life you can use bigger batteries, on all the newer Samsung devices it’s easy to twist the wires, no soldering necessary, I use CR123’s.


Hi @Mariano_Colmenarejo

So after a bit of testing I see the temp offset is actually just a “temp offset” I was thinking it was report temp change after temp changes by X number of degrees.

I think I have it working. I set the range from 1…120. And it appear to only update every 1min if there’s a 0.1C temp change, which of course it easy to happen, so I see why the battery will go quickly with that in normal use.

So I think I’m going to change all my Samsung sensors to your new DTH and set them all to 120 or 240 or 480 because I don’t need temp on my door, window and leak sensors at all.

On a side note:
I was told your DTH run locally. How do they run locally? I thought all custom DTHs run in the cloud?
Is it because it’s based on the official one and you are just changing a parameter?

I notice if I change back to the original default SmartSense Button DTH the time setting is still in the Settings in the app but it seems to have reverted back to 5min updates (which makes sense). But why is the TempReportTimeMax still showing up in the Settings?

Thanks again!

Thanks Alwas. Once I get it setup and working and find the interval I need then that will probably be something I’ll end up doing.

In IDE change the version of the DTH from published to self published or vice versa, it does not matter and update.
If it does not disappear, from IDE edit the preferences and set the TempReportTimeMax to null and save.
Even when you change the DTH, the variables are not initialized and having a value assigned, it is displayed.
That it is local execution, must be because it is the original modified, I don’t know.

1 Like

Hi @Mariano_Colmenarejo

I removed the value in TempReportTimeMax and then changed the DTH to the original and it removed it.


1 Like

Hi @Lain, when You change the Interval setting in app, you must be update the versión DTH in IDE for configuration excursión. I try to resolver this issue, sorry


Seems to be working well so far.
Once I get the smart vents I’ll be able to fine tune the time.

Thanks again for the DTHs!

Have a great day!


Thanks to the community we all learn!

happy end of year!

1 Like

Hi @Mariano_Colmenarejo

Having an issue with the button, leaks and multi sensor. They are all updating at the default 5min.

I tried deleting and readding the DTH, taking the batteries in and out, changing the settings, etc and I can’t get them to be anything but 5min.

I did have the button working at 1min but now I can’t get any of them to change from the default 5min.

Any idea what might be wrong?


When you edit the device, swap over “Published” to “Self Published” or vice versa, and hit “Save”.

Tired it, update in 5min again when set at 10min.