SwitchBot thermometer readings not updating automatically

I have a SwitchBot Hub Mini with a SwitchBot Thermometer connected to it.

I added my SwitchBot account in SmartThings using the official integration, and I do see my thermometer in there (including the temperature and humidity readings), however the values only seem to update in SmartThings when I manually refresh them (i.e. click on the thermometer and swipe down). If I don’t touch anything then SmartThings doesn’t appear to fetch updated values at all: I’ve tried leaving things alone for 6 hours and I still see the values from the last time I manually updated it (the “History” tab doesn’t show anything either, even though in the SwitchBot app I see updates every 30 minutes).

I know it’s not an issue with my SmartThings Hub since I also have my power meter in there and it’s getting updated values from it every minute with no problem whatsoever. And it’s not a connectivity issue since manual refreshes always work. At this point my guess is that this is how the integration was written, but since I’m using the official integration I can’t delve into the code (or can I? I’m new to SmartThings). I know the integration is fairly recent (less than a year old) and it’s cloud to cloud rather than local, so maybe they disabled automatic updates fearing how much traffic that would generate for them?

Anyway, if anyone has the same issue and / or ideas on how to fix this, that’d be greatly appreciated!

At this point it is the individual device manufacturers who are responsible for maintaining the integrations that appear in the app. So you would need to contact SwitchBot support and ask them if there is a way to increase the refresh on the thermometer values.

My experience is that their support has been knowledgeable and helpful, but there can be some language issues and it can take a few days to get a response.

I believe there is a Facebook group, but I don’t know anything about it. They used to have a community forum, but it was discontinued.

1 Like

Has this been fixed?


I tried the SwitchBot Facebook group and they told me to open a ticket from within the app. I did that and they replied (typos are theirs): “We have been trying to have them (the SmartThing) solved this problem. If there is any update, we will inform you.”

That was on September 30th and I haven’t heard anything since, nor is it working properly in my SmartThings app (although I haven’t tried deleting them and re-adding them since that day).

It sucks because that’s one of the few humidity sensors which works with SmartThings (there are tons of cheap temperature sensors , but very few of them also give humidity readings). Instead I bought a bunch of Aqara sensors, which are about the same price and size (well half the size really - at that point it doesn’t matter much). They do have two drawbacks: they don’t have a screen to show the reading without checking the app, and they don’t officially work with SmartThings (although I haven’t had an issue so far, but I thoroughly read all the integration warnings on the relevant threads of this forum).

I use the aqara too, but I make sure to pair them while right next to the hub to try and avoid repeaters between them and the hub.