Suggestions on how to fix a crash on the Android ST app when adopting in "My Testing Devices"

When I adopt my device under My Testing devices everything works up to the last screen where it said it was successful and has an “Done” button on the bottom. When I press done it crashes and the device is never added :frowning:

I tried uninstalling but that did not seem to work so I am starting to think the issue is in my account itself?

suggestions and ideas appreciated.


Hello, @mathewss! Can you provide more details, please?

  • What kind of device are you trying to integrate? (cloud-connected, hub-connected > Zigbee, Z-Wave)
  • Is it a custom handler you made? If so, please share its configuration (in the Developer Workspace and source-code if possible)

It is a direct connected device using:
GitHub - SmartThingsCommunity/st-device-sdk-c-ref: SmartThings SDK Reference for Direct Connected Devi
The project and firmware are here.
GitHub - nutechsoftware/AlarmDecoder-IoT: AlarmDecoder Internet Of Things

Others have used this firmware recently and have successfully adopted so again it seems like the problem is on my profile.


Just noticed I had an update available for the App. I was running
I ran the update and now I am on

I will keep kicking it see if I can get this working again.

Now it does not start adopting before it shows this error :frowning:

I see…just to discard possibilities.

  • Make sure you’re using the last published version of the ST mobile app. (I see you already checked that)
  • Also, to avoid any cache issues in Android devices, you can go to the mobile device settings > apps > SmartThings App > storage > clear cache

If you already verified that, please send us an email to with your Onboarding_config.json file.

Yep tried clearing cache same error.

Email sent.