Stuck Between Both ST Apps - Smart Home Monitor


I’m currently stuck between the new and Classic ST apps. I got the grand idea to switch to the new app as it’s been out for a while now and I figured all the bugs had been worked out. Boy was I wrong.

I can’t get Smart Home Monitor installed on the new app. It lets me go through the config of security, fire and water sensors, but when I finish the app isn’t installed. It just says add new app. Is this because Smart Home Monitor is installed in Classic? If so, how do I remove it from Classic and get it in the new app?

I have to say I’m extremely disappointed in the complete failure I’ve experienced in the switch from Classic to the new app. I’m several thousand dollars invested in this platform with over 150 devices connected in my home. The fact that the new Alexa Skill just doesn’t work AT ALL is completely unacceptable. Had I known that I never would have started the transition. What the heck is going on?

1 Like

No, you can have both installed but most folks get confused when an alert is generated. They forget that they are separate apps and that they need to dismiss the alerts in both apps.

Try uninstalling the ST app, reboot your device, reinstall the ST app and then try to install STHM.

I’m sorry you’ve run into so much trouble, and I don’t have any advice on that. Hopefully what @jkp suggested will help.

Meanwhile, it is important to note that the security feature in the new V3 app is different from the one in the old app. And you need to have deleted any of your alerts in the old app before you remove SHM or you will not be able to remove them, which is really annoying. See the FAQ for additional issues. (The topic title is a clickable link)

Hey JKP. Ok I uninstalled / reinstalled the new app and tried to reconfigure SmartThings Security Monitor with no change in behavior. Once the config is complete and you go back the app is not installed. Screenshot_20200712-154127_SmartThings|243x500

Do you have any malware blocker such as adguaed or pihole on your home network?

Neither of those, but I do have some blocking features enabled on my Asus AC-RT5300 router. Not sure how that would affect an app inside an app though. Enabling Home Monitor in Classic works.

It can!

whitelist and and try again

1 Like

I will take a look this evening. Thanks!

Here is another possible solution you could try.