STHM "Server Error". How to fix?

I see others have had the same problem, but I haven’t found a consistent resolution yet. Because of other problems, it was recommended I uninstall and reinstall STHM which worked great.

Tonight at midnight, I went to disarm the system (previously armed) and I was given a “server error” message. I tried to refresh the status from the button and still Server Error. I tried to force quit the app and still Server Error.

I uninstalled the app again, set it back up with no unique settings (just next after next), went back to the main menu, and was still given “server error”.

I logged into the IDE to make sure I didn’t have an old STHM from the classic app and I do not.

What troubleshooting data can I collect to share, and what’s the right way to engage support?


I have the same problem. It shows up periodically and looks normal but when i press any button such as Disarm everything freezes and it says server error. What is even worse is that the alarm goes off because of some automations that is triggered when arming but funny thing is that it shouldn’t because the conditions has not been fulfilled. I reinstalled sthm and now it only says server error.

1 Like

This is happening to me too this morning. I haven’t emailed support yet. I’m not in the mood for their standard delayed response, so I’ll wait for a bit.

tagging @SmartThings

I emailed them. They told me to reinstall the app. I really dislike their tech support since being bought by Samsung. Used to be so much better.


Same problem here. Getting texts every time a door to the house is opened, but don’t have an alarm fortunately. Also glad it broke while armed stay and not away! I also noticed my room and device layout in the app reset at one point, but then I forced closed and reoepend and it when back to normal. I haven’t updated to the new app version with Android auto yet so that’s not it.

Going to give it more time to fix itself before I waste my time with support.

1 Like

so, how many times will i set off intrusion alert with STHM this morning? that is the question. so far, i am at 3.


Having the same problem. Set my alarm off twice before I managed to disconnect the alarm. If anyone figures out how to correct the server error or gets in touch with Samsung, please post. When I tried calling they said they were closed.

1 Like

Same here, but it’s more than just STHM. I’m seeing delays and timeouts in voice control via Google Assistant too. I suspect the ongoing performance problems that started on Jan 14 may be at the bottom of this, and it just happens to have got worse overnight.

Now that you mentioned it, I noticed that too with GH today. My ActionTiles also are slow/buggy today.

If support gave a dollar to the developers every time they told us to reinstall the app, SmartThings would be the finest, most well-funded cloud platform in existence.


Somehow, for a very brief moment, I was able to get into STHM and turn off Security. Thank goodness because my wife was getting really PO’d. I still never got any notification of an intrusion or the option to dismiss it in the app. What a total POS. This app is getting worse, not better.

Same here too now. Once of my voice commands to run a scene came back from Alexa as “not responding” but ST still did what it was suppose to do, including sending a push that it ran.

Hey, but at least us Android users now have Android Auto! … sarcasm …

tagging @vlad

1 Like

Can you give @vlad your ticket number? He’s also tracking down stuff not working from this thread:

Same here. Can’t disarm, server error for STHM. Alarm goes off every time the door is opened. Ugh.

Same problem here ST Home Monitor Server Error. Stuck in Arm Away mode. Following this.

Adding my name to the list.

My workaround for this morning was to open the door and then take the battery out of the door sensor so I can come and go without it tripping repeatedly. But I’m getting very close to ordering a Hubitat. I’ve had more problems in the last few months than in the 4 years prior to that combined, and there’s no indication things are improving.

Edit: it seems STHM does not alarm on the ‘tamper’ state that some sensors use when you open the battery compartment, so if your door sensors do this and do not set the ‘open’ state when you open the battery compartment you can just pull the battery with the door closed.

Create a temporary automation. Setup a check for a button that is turned on or off and set action to disarm. After that you can judt delete that automation. Not a workaround but a way to disarm at least.

1 Like

Add me to the list of users experiencing this. Super annoying.

Same here. Can’t disarm, or arm server error for STHM

Same here. Can’t disarm, server error for STHM