Stelpro Maestro SMT402 unable to adjust temperature in SmartThings after Controller v. 2.1.19-7

SmartThings iOS v. 1.6.52-437

I have 3 of Stelpro Maestro’s and they’ve been working great. However, SmartThings app just updated them to Controller version 2.1.19-7 and now I no longer can change the temp from within SmartThings. Before the update, there was a + and a - section letting me adjust the temp setting. I’ve reset to default and reinstalled and still not showing.

Same happened to me tonight.

Same here with 2 of my Stelpro Ki thermostats! Wouldn’t be so bad if the house was closer than 180 miles where renters are checking in at noon…

Same here, I have 15 Stelpro KI’s and overnight the ability to change the temp has disappeared on all of them.

1 Like

Same here. The only way I can control them now is via Alexa. GOOGLE assistant or through setting up automation. If anyone has a solution to bring back manual control that would be awesome. So much for testing updates before letting it free into the wild. :frowning:

make sure you report to support so they know the urgency

1 Like

k, I sent in an email to SmartThings Technical Support on it.

Support has had me clear cache, uninstall and reinstall the app. Support can see my devices are active in my account. I’m working with them still to help them understand that the adjusting the temperature remotely in the app has disappeared since the last controller update…will update as I get more.


Report it to

I have the same issue with Stelpro Maestro SMt402 and KI in Smartthings on my Ipad, but on my iphone it is working fine. (Same version of Smartthings and IOS)

The response I got to my support request (ticket) was insane!

He tried to convince me that I needed to change the temperature setting to F instead of C!
It took everything in my being not to call him a jackass in my reply!!!


There was a plug-in update over the weekend which likely caused the controls to disappear. If your ST app hasn’t downloaded the new plugin then it should continue to work.

1 Like

Sometimes you have to wonder where these people come from. :slight_smile:

And if it did update…what are we supposed to do?

Luckily the automation and Alexa still works.

Not to hijack, but while we all wait (including us non-Stelpro guys) for a fix, can anyone remember if you could adjust your Stelpros in .5 degree (Celsius) increments with the new app? I can do that for my non-Stelpros on the classic android app, but the new one (when it was working) only allowed it in full degrees. I’m assuming that was a new “feature” for all thermostats?

@BGrudgingLee, If I recall correctly, it reported .5 degrees but set temperature was limited to 1 degree increments.

All others, I too have found support@smartThings to be absolutely useless. They don’t know anything about their new SmartThings app, let alone any 3rd Party "SmartApp"s. They will simply send you boilerplate responses to reinstall everything over and over again. Please don’t suggest emailing unless you want to waste your time. Maybe try instead.

I have the same problem…

Also my presence sensor is not beeping at all. wtf…

I have a bunch of Stelpro Ki as well as a couple Sinope thermostats. This happened to all of them within last few days. Samsung support says to reinstall them, but I am not at site until Friday…

Don’t bother, reinstalling will not help. It’s a Samsung smartthings issue. Only they can fix. They broke it. We simply have to wait for their developers or build a smartthings-proof custom device handler. Sorry :frowning:

Thank you. Can we assume they know? Or should everyone report problem?

Thank you, Eric