SmartThings platform Change?

Hello,

I work for Stelpro and i have been working on getting the Maestro SMT402AD model certified with smart things. I was able to build the Maestro driver into the smartthings app in the beggining of 2024 and had all the features up and running, however around april 6th, all of the sudden, the SMT402AD did not want to build anymore, nothing was changed on my side. It started to show up as zigbee thing upon pairing. I am sure something has changed in the smartthings platform, the maestro firmware did not change (i work as QA here) and we dont have updates for this model.
I had done a lot of investigation before, and realized that if the model is wrong throughout the driver files we get the zigbee thing, so i was able to fix it by using the right model which is SMT402AD (even though it is written SMT402AD01 in the back of the thermostat).

Any help will be greatly appreciated

Hello @GustavoAragao
It weird to say but glad (somewhat) somebody is having similar issues as me with the SMT402AD01 model. Since my original post here about the Zigee Maestro Thermostat I have not been successful in adding them, despite the fingerprints added to Mariano’s driver. I was about to trash them but decided to hold on to those 2 units for a little while, just in case i would eventually find a solution.

I am not sure I understand your very last part, did you end up forcing a model number and it now works? If so, I would be more than interested to see how you did this and would be willing to try your driver. Or does it still show as Zigbee Thing ? Nonetheless, I am willing to contribute. You can share your channel in private message if you wish, I can give it a try on my side.

I am guessing we could work together in getting this specific model compatible with the platform. Let me know if interested :slight_smile: My other thermostats SMT402AD still work to date but have not tried to repair them, only problem with SMT402AD01.

1 Like

Hello @ellie,
I am working on the smartthings integration/certification for 2 Stelpro thermostats (SAT402ZB and SMT402AD01)
Here is what i did:

  • I had downloaded the drivers from github (maestro drivers) and populated the files (fingerprints,subdrivers,etc…) with the each thermostat model and manufacturer
  • Then using smartthings CLI i pushed the drivers to the smartthings hub and paired them using the samsung mobile app

Here is what happened:
I was able to control both thermostats with the smartthings app without any problem. However at a certain point (MID april) while i was working on the pre-certification test, i had to re build those drivers, so i deleted everything and pushed them again. The SAT402ZB was paired successfully and i was even able to run the pre-certification tests on it. But while pairing the SMT402AD01, it shows up as zigbee thing on the samsung app.

Just to clarify something: The maestro thermostat i have here is the SMT402AD01 model rev09, but the driver files were populated with SMT402AD, so i believe this is the right model to use, since it worked before.

This morning i will try to rebuild the SAT402ZB just for fun to see what happens, also it is important to note that the SAT402ZB thermostat has a different manufacturer name which is: Stello. So if that pairs successfully i assume that the issue is specific to the Stelpro SMT402AD model. I have sent the logs to Samsung and the engineering team is currently looking at the issue. In any case i am pretty sure this is an issue with the smartthings platform due to some sort of updates or whatever.
I hope that helps and thanks for jumping in. I will stay in touch regarding my findings

Hello again,

FYI: I was able just now to pair my other thermostat (the SAT402ZB), so the problem really seems to be with the Stelpro brand specifically, i know that there was a brand migration (for Stelpro) to the a new platform in april that could have affected it, thats my guess. I just sent the information to support and lets see what they will say. My guess is that something happened on the platform side that affected the Stelpro integration.

You said your SMT402AD still works, i believe you did not repair it after april, am i correct? my guess is that it will certainly stop working if you repair it, that’s what happened to me.

1 Like

hello @GustavoAragao
Thanks for the details and clarification, your steps and analysis do make sense to me (I come from IT world :slight_smile:
So to answer your question, no I have not repaired them since April. I started trying installing my SMT402AD01 Rev09 (yes exact same as yours) in the month on May without success, I was so puzzled and did not understand why.
Happy to hear that someone at Stelpro is looking into making them available natively with Smartthings as I have been a good customer for years and own several of this brand or subsidiary Uniwatt. Let me know if I can help in any way with Beta testing.
Talk soon! Hopefully the engineers will resolve this timely.

Hi @ellie ,

Just to let you know that, i am submitting a pull request today, despite of the fact that the SMT402AD driver is not onboarding correctly, support asked me to submit it anyways, if there is any issue, the engineering team will deal with it directly from the hub side. I will keep you posted, we should have the device certified very soon, meaning the good drivers will be deployed and ready to be paired without any issues.

Thanks for your engagement on this, i will stay in touch

2 Likes

Just wondering if there has been any news on this. I am having the same issue and trying to setup 4 of these thermostats under SmartThings but they are still showing up as a Zigbee Thing. Presently have them added to Home Assistant (no issues pairing to that platform) but want to use SmartThings. Thank you.

1 Like

Hi Tim,

I am currently running into a troubleshooting with the Stelpro Maestro SMT402AD model. We are trying to solve the onboarding issue prior to the smartthings certification. I will keep you posted as soon as we have that driver onboarded succesfully.

Regards

1 Like

Perfect, thank you! That is the exact same model I am using. Let me know if you need any help testing anything.

1 Like

Hello fellow @Tim_Burke
My Stelpro SMT402AD are currently using Mariano’s edge driver available using this link
“Zigbee Thermostat MC”

Have you tried this custom driver in the interim until they are natively recognized by Smartthings ? Maybe you already have :slight_smile:

1 Like

Yes, I tried that and unfortunately under SmartThings it only gets recognized as a ‘Zigbee Thing’ even when right beside the hub, and when I try to switch the driver to ‘Zigbee Thermostat MC’ it doesn’t show up as an available option (subscribed and enrolled).

I think it’s because for whatever reason the model number isn’t showing up properly in SmartThings itself. Strange though it works in HomeAssistant and used to work in SmartThings before I deleted and re-paired again. I see others have had the same problem though.

All good, I will wait until it is natively recognized. Thank you though. Much appreciated!