ST Geofencing problem Android 13!

Smartthings Geofencing stopped working when phone updated to Android 13!
Phone works Ok with other apps and all… also maps and other routes like Google maps.

2 Phones connected to work with Geofencing and this Android 13 phone (1) is always ‘Away’ in Smartthings.
Geofencing switches ‘Away’ when phone (2) goes away and phone (1) is still home.

Have you enabled settings, apps, smartthings, permissions, location permissions, allow all the time and use precise location. Also enabled allow nearby devices? Also switch off Pause app activity if unused.

Yes, all have been the way you wrote, always.

This has been working in some way until Android update.
Have to say this ST geofencing has never been that good what hoped. Every time ST app has been updated each phone positioning has to be set again “Get location from this phone”, without doing anything else there, just click that property once and return.

I’ve had problems in the past–especially when transferring/upgrading to a new phone–with geolocation on ST, Nest, etc. It seems that it worked better if I deleted the app and reinstalled it–somehow that helped the Android OS know I wanted to location permissions (even though it still had them). If you haven’t tried that, give that a try…you’ll have to reenable all the permissions–background running, location (in Android and in the app), etc.


Nice to know that similar problems exists… :joy:
Yes, uninstall/reinstall is in my todo list next if there is not rising any shortcut to solve this…

I don’t think anyone has completely pinned down the reason geofencing is unreliable on any phone or any OS.

FWIW, presence sensing with my Google Pixel 4A-5G works just fine.

I had a phone upgrade to Android 12 around the time of the last app update. One or both of those has broken the address geocoding so although the geolocation is set (I have other phones using it), and the app happily lets me turn on the location sensing, it can neither search for an address or report the existing geolocation as an address, and so it reports that the location isn’t set.

This is the first time I’ve experienced technical issues like this with presence since the days of the Classic app. Different places are hit and miss, but it has always been capable of working.

I did uninstall/install the APP and seems to solve the problem. Al least it worked nicely today when tried one reality test…

Thanks to all for good feedback!