Geofencing triggers don't work after changing phone from S10 to Pixel 7 Pro

I switched from a Samsung S10 to Pixel 7 Pro 2 months ago and my geofencing triggers have been hit-and-miss. On a good day they would trigger at the same time Google Home does, on a bad day the app doesn’t even realize I am miles/kilometres away from home. I have four routines, one being manual that just changes the phone’s location mode to Home. Of the three geofencing-triggered routines, one changes the location mode to Away when everyone (me) leaves home with the precondition the location mode is Home. Of the other two routines, they both call the manual routine when someone comes home with the precondition the location mode is Away. The differences between these two routines is one has a second precondition of Sunrise-Sunset while the other has a precondition of Sunset-Sunrise and turns on a light.

These routines had worked very well until August when I changed phone. I have tried to uninstall and reinstall the app and cleared the cache and delete home address. The app has continuous access to location and unrestricted battery usage. Also, I notice that when I try to set home’s geofence the app gives the address of a specific unit in another tower (I live in a two-tower strata property). I have tried using that address but it didn’t fix anything. I am a very technical person but this has really stumped me.

I upgraded to Android 14 and thought the geofencing issues would be resolved but they haven’t.

I gave up on ST location tracking a long time ago due to inconsistencies on both Android and iOS devices. I switched to using Alexa location tracking for my geofencing and using virtual devices in ST to represent my presence. Alexa then can turn on/off the virtual presence devices which are used in my ST Routines.

1 Like

Unfortunately, Alexa’s geofencing is not available in Canada.

I am now considering getting a door sensor to trigger turning on the light at night when the door opens.

when you switched phones… did you do a transfer to the new phone or a fresh install of the ST app?

I did a transfer as it was available. When I started noticing the geofencing issues I did some research online and found a post that suggested doing a fresh install so I uninstalled, restarted the phone, then installed again but same results. I have done the uninstall-then-reinstall a few times, both under Android 13 and 14.

but did you disable get location at any point?


  • disable get location for this phone in the ST app
  • remove the app
  • reboot your phone
  • login to Advanced Web App to ensure the mobile device has been removed.
  • reinstall ST app and enable get location for this phone

not saying it will resolve the issue but worth trying :slight_smile:

1 Like

After two weeks of trying many different things, geofencing is still not working. I have tried disabling SmartThings from getting the location from the phone before deleting the location, rules, and scenes in Advanced Web App and then uninstalling SmartThings from the phone before reinstalling it. I have turned on WiFi even when outside of WiFi ranges, and have turned on scanning bluetooth even though my bluetooth is turned on for my Fitbit anyway. Geofencing would work one evening when I go to the mall across the street or the public market a few blocks away, then stop the next day. For some reason yesterday the home rule got triggered when I was barely inside the 150-metre geofencing, then quit when I left home again. I have been trying to watch for a pattern but there isn’t any. It doesn’t matter whether I am walking or on the subway.

I noticed something interesting on my phone’s app settings yesterday. It shows SmartThings only seems to access the location (as shown in location permission) if I open the app. However, even then it doesn’t detect I am home or away half an hour later. I am beginning to think maybe having scenes that set location modems somehow might have something to do, or maybe geofencing started being an issue as of Android 13 as my old S10 was running Android 12.

For what it’s worth I have a Pixel 4a-5g. It was upgraded from Android 13 to 14 a couple of months ago. (Your Pixel 7 should update if you try)

Location/geofencing is good for me about 95% of the time. I have a metal roof that blocks GPS so the phone has to use the known location of my Wi-Fi when I get home. It occasionally glitches but I think it’s better with Android 14 than it was with 13.

You haven’t mentioned two things that need to be checked

  1. Location permission needs to be set to Allow all the time

  2. Pause app activity if unused needs to be turned off

To change the settings, touch and hold the app icon and tap App Info, then Permissions.

1 Like

A completely separate issue, but since you mentioned location modes…

Some Routines that set location modes broke for many people on 15 November 2023, regardless of the type of phone they are using. Even if the routines had previously worked fine. So that might at least have interfered with your testing.

The good news is that problem appears to have been fixed on 18 November 2023, although in a few cases people had to recreate the routines they had been using.


Location Mode Changes Failing (15 Nov 2023)

1 Like

After a month of hopes, frustrations, uninstalling and reinstalling of SmartThings, plus many different setting changes and theories, I have come to the sad the conclusion that geofencing is completely unreliable on the Pixel 7 Pro. While the Home trigger routine worked sometimes, the Away trigger routine hardly ever works. I have unstalled SmartThings after disabling getting location from phone, then deleting my home location in Advanced Web. I have left WiFi on for hours, removed phone case, and turned off pause app activity if unused. I have also given unrestricted data to Google Connectivity Services. And yes, location access is allowed all the time, and battery usage is unrestricted.

I can use the smart lock to change mode from Away to Home when it is unlocked with the precondition of location mdoe being Away now, but I have to manually change the location mode to Away when going out.

Some observations of strange behaviours:

  • Location mode usuauly only changes to Away if I walk a few blocks away from home, but seldom when I drive or take public transit, even if to go to work and after arriving in another city over 10 Km away.
  • One time: Location mode changed to Home from Away after I had turned on WiFi while standing outside my door. Yet stays as Home even when I am at work and connected to workl’s WiFi for a long time.
  • One time: Location mode stayed as Away but History showed routine to change to Home location mode had been triggered, then location mode changed to Home. Synching issue?
  • Routines always take one or two seconds to show up on phone’s screen.
  • SmartThings and other apps that support geofencing always identifies my home address as a specific unit number in the adjacent building. And the longtitude/latitude of my actual homne address shown in Advanced Web is incorrect.
  • Used work address yesterday as home address and saw location mode automatically changed back to Home after I had manually changed it to Away, indicating the Home routine worked.

I started fresh again on Thursday while at work and the Away routine still wouldn’t trigger (Precondition: Home location mode [removed later], Condition: When all members [me] leave, Action: Change location mode to Away). I increased the radius of the geofence from 150m to 200 and the Away routine triggered yesterday when I went across the street to the mall, then drove 35+ Km away. I did notice a few minute delay. Yesterday evening the Away triggered also happened but a few minutes late.

Today, the Away routine did not trigger at all when I walked to the recycling depot, then to the public market – well out of the geofence. So much for getting my hopes up yesterday.

1 Like

My household has three users: two using the Pixel 8 Pro and one using the Pixel 8. The problem is 100% the SmartThings app, because we have lots of other apps that use geofencing with our phones without problems. We have third party apps from other companies (eufy, wyze, etc) that enable and disable security cameras and features, as well as robot vacuums, etc., based on our phones’ location. Even the native Google Maps with location sharing enabled sends me timely notifications when each of us arrive and leave home, work, school, and the gym.

Three months have gone by since my last post, and this will be my final post as I have now given up on SmartThings. However, I want to just give a final update on how I had tried to accomplish what I needed to do.

Geofencing never worked again, or at least didn’t trigger soon enough for me to ever notice it was working. I started trying Google Home’s Home and Away and while it has not been perfect as it would not switch to Away for days and missed Home quite frequently, it has been MUCH more reliable than SmartThings. While I am certain my Pixel 7 Pro is also responsible, I prefer unreliable over non-existing. For a long time I used both Google Home and SmartThings side-by-side by using a smart plug as a “bridge”. When Google Home knew I had left the geofence it would turn on the smart plug which would then trigger SmartThings to switch to Away and then turn off the smart plug. When coming home SmartThings would switch to Home when the smart lock is unlocked, and another routine would get triggered to turn on a light if it is night time. Everything worked quite well as long as there was no power failure or in a few cases, the smart lock lost its WiFi connection.

I resisted using Smart Things’ virtual switches instead of the smart plug because I liked each system to be connected to the various smart devices on their own instead of Google Home having to link to Smart Things to control the devices. Eventually I decided the smart plug idea wasn’t working very well and switched to using a virtual switch. During this time I had also tried Google Home’s script editor. The first script resulted in the smart lock not knowing when it is locked or unlocked, possibly because I had not coded for decades. Maybe it is the smart lock manufacturer’s firmware and app updates, or maybe Google fixed its scripting system but I noticed yesterday that one of the sample scripts does exactly what I have wanted to do: turning on lights when door is unlocked. I copy-and-pasted the code, made some slight modification to make sure the light would not turn on when the smart lock is unlocked while someone is leaving, and it worked perfectly when I came home from work.

Tonight I found out about Google Home Playground and guess what? It supports virtual devices which means I can turn on a virtual switch when I am in the geofence which would trigger a routine to turn on a light if it is night time. After six months, I finally got the automation I wanted.

Good bye SmartThings. I enjoyed our time together.

P.S. I also tried out Home Assistant using a Raspberry Pi 3B+ but gave up on it as my smart plugs and smart switches were the only devices that would work.