Geofence Stopped Working on iPhone

Long story short I have an iPhone 12 and was forced to upgrade to iOS15 and reset my network settings. Since then, ST doesn’t know when I leave or arrive. As soon as I open the app it will detect where I am and execute automations based on location. All other apps using geofencing still work, so it seems to be local to ST.

I toggled the “Get your location from this phone” off/on with no change. ST is setup to use always allow location services in the Privacy settings in my iPhone. I also deleted the ST app and reinstalled.

I spent a good hour with ST tech support yesterday and it worked twice. Back to not working now two hours later. We deleted/reinstalled app, shut off/turn back on presence sensor, delete/recreate automations, made geofence as small as it can be… I’m lost.

Any help is appreciated.

Thank you - I will try your suggestions in that sequence and follow up. For my understanding… This is an iOS15 issue that only effects ST (I am on 15.0.2)?

I am on 15.1 (beta so higher version than yours :slight_smile: )

iOS generally has a few bugs after initial release but they get resolved

OK… I performed the steps in order, I haven’t had a chance to return home to see if geofencing is working, but, I had to recreate my automations for leaving and coming home and noticed this:

All of my scenes look like this… I can go to each device individually and they are available/online and look good in IDE. If I try to edit or recreate the scene I can’t even choose a device to control:

I’m afraid I’m really in a mess now. Any ideas @Brad_ST ?

Interesting… now you appear to behaving an issue similar to this thread but not exactly the same …

I have no clue except to say contact support again. My guess is …it may have messed with STHM somehow. I better refer you to support at this point. This makes no sense.

I removed my post above so as to not cause issues for others

Well… As expected that was NO help. Their only suggestion is to delete all devices and reinstall them which makes no sense as they are all online in IDE and available individually… :frowning:

I wish I knew… What I can tell you is the scenes (and automations that call them) still appear to execute, even looking like they do. There’s just no adding new or editing existing at this point… I won’t know until this afternoon about the geofence. I just don’t understand what has happened :disappointed:

looks like something is going on…



Just got home. My automations/scenes executed. Everything seems to be working (including the geofence). With the exception of all of my devices being unavailable in automations and scenes (shown in pictures from previous post in this thread) everything seems to be working…?

For clarification - the devices can be controlled individually, they are just not available to create a new scene or automation and show unavailable in current scenes and automations.

Thanks for the update @jkp! Please keep me posted and I’ll do the same.

1 Like

I was experiencing a similar issue with my Android. Just got off the phone with SmartThings support and was told that:

  • The developers recently disabled geofencing due to a bug
  • They don’t have an ETA when this will be fixed.


Hi, I upgraded from an iphone11 to iPhone 13. Also updated the iOS to the latest as of last night. Ever since the upgrade geofencing does not work.

I have done everything!
Reset locations services
Reinstalled the app
Switched from location services while app is in use to always and back and forth.
Reset the whole phone
Time zone setting verification
Verified app settings, location setting is set and correct…
Get location from this phone is set in the app.
And much more.

Doesn’t work and very frustrating. Used Smartthings since it first came out. A shame the basics don’t work now.

Any advice would be appreciated.

Only solution I know of is you have to leave the app “minimized” and it works flawlessly. Frustrating for me as I always close my apps , but… ST says it shouldn’t have ever worked with the app closed, but it did for me until I upgraded iOS.


Bill Wolfe

The latest iOS released yesterday seems to have fixed the issue.

I’m having the same issue (iOS 15.2). Which iOS upgrade fixed it for you? Thanks.

1 Like

Hi, I could have sworn I had 15.2 and then another update happened that fixed my issue. Maybe I was on 15.1 or perhaps installed 15.2 release candidate 2… honestly not sure but could have sworn I was in 15.2 and another update came out for 15.2.

Sorry I can’t be of more help.

Never mind worked once and not working again. Very frustrating.

I upgraded latest iOS today. No change. Still have to leave the app open and it works…


Bill Wolfe

If you can’t beat 'em, join 'em! I know this is a brutal hack, but let’s try using an IOS shortcut to keep the app open when leaving the home location. In my case, I’m using an iOS shortcut (considered an automation) when I connect to Bluetooth in mine or my wife’s car. This simple automation opens the SmartThings app. For safety’s sake, I will also create a location based shortcut when I leave and arrive at home. All this just to keep the app open. Here is a link to the Apple shortcut stuff: Setting triggers in Shortcuts on iPhone or iPad - Apple Support

I know, grrrrr!! Hopefully this gets fixed by Apple, soon.

Good idea! Thanks!

Interesting tidbit… ST now knows when I leave (with app closed) but doesn’t know when I return (with app closed).

What was the solution ? I can’t see the reply you are referring to. Please help I’m also lost.