ST "forgets" GE switches occasionally

jasco

(Steve S) #1

About once a month, ST will “forget” one of my z-wave switches (I have over 20 of the GE/Jasco switches). The symptom is that one of my switches will just stop responding to commands from the iPhone app… physically operating the switch works fine, but it will not work from any apps or by direct control via its device tile.

The only thing that works is to delete/re-add it in ST. The funny thing is when I delete the device and the ST app says the hub is in exclusion mode, I then press the switch and the app immediately say “Oops! Looks like you may have excluded the wrong device!” Then I have to “Force Delete” it. At that point, I can add it as normal (so obviously the exclusion worked) - and then it will work properly again. A few weeks later, rinse and repeat with another random switch.

Is this a known issue? It seems like the Hub looses the ID of the device (or it gets corrupted or similar) because when I try to exclude it, it doesn’t recognize it as the correct switch. I have over 40 devices associated with my hub, if that matters.

Anyone else see this behavior?


(Coolcatiger) #2

It happened to me last month. I had delete all switches / apps and redo the stuff.
I hope it does not happen again.

It was very painfull. It seems that the zwave routing table got corrupted.


(Beckwith) #3

@stevesell
@surajt

Did you happen to try “Repair Z-Wave network” from the IDE? I find it may take a couple of attempts if you get errors and sometimes a hub reboot. It seems to have worked for me when a device fails to respond. In my case it generally happens when I add a new device or power down one, but not out of the blue as in your case.


(Blake Westerdahl) #4

I just had the same thing happen with one of my GE/Jasco switches. I initially thought the z-wave radio in the switch had died (I have had this happen before as well) but force deleting it and re-adding it made it work like a champ again.

I definitely think it could be something with the routing table. My affected switch is the most isolated all of my devices. It is within 10-15 feet of at least three other devices but has no direct line of sight (one or two walls in the way). All of the other switches are within a direct line of sight or within a few feet of each other.

With my Vera, I could see the routing table and figure out where the communication break down was occurring. I could also run a network heal to have the routing table rebuilt. In SmartThings, I tried running the Z-wave network repair utility through IDE but the only result I got was that it couldn’t find the affected switch.


(Coolcatiger) #5

Ran repair, but it used to fail all the time until I re added switches.


(Beckwith) #6

@trotsky40

I find you need to turn logs on or you won’t necessarily see the issue even if the repair fails or succeeds.

Has anyone tried “Enable Z-Wave Debug Mode” which seems to be a recent addition to the IDE?


(Beckwith) #7

@coolcatiger

I had a device listed that was no longer there. Don’t know how it got there, maybe I included it and did not exclude it. It no longer showed in the list of devices. However, when I repaired the network, it would say it succeeded but logs listed the missing device as failed. I rebooted the hub and ran repair and it cleared it up the other device which failed.


(Blake Westerdahl) #8

@beckwith

I used the logs and got two errors for the switch when I ran network repair: unable to find switch and unable to update route.

Also, what firmware is your hub running (I am on 11.00603)? I don’t see an Z-wave debug mode.


(Beckwith) #9

@trotsky40

I’ve had that happen and multiple repairs and maybe hub reboots eventually fixed it. Now I don’t know if this was just coincidence, luck or a bona fide solution, but it may be worth a try next time.


#10

How timely…I’ve just had a GE dimmer just decide to stop working about an hour ago, so I came to the forum to search for how to exclude it so I can re-add it. Ever so often ST just “forgets” a switch, and it’s a pain to set things back up…


(Steve S) #11

All - just to follow up, I contacted support and this “forgetting switches” or perhaps routing table corruption is apparently a known issue. Here’s the reply I received:

Hey Steve,

Thanks for reaching out. Yes, this was actually a known issue. We’ve since corrected the problem in the most recent firmware version which I’ve just pushed your way.

You should be good to go from here on out – you may just need to power cycle the hub (or device itself) if you have any residual issues. You definitely won’t need to remove/reconnect any devices.

Hope that helps!

Charlie

For what it’s worth, my hub shows 000.011.00603 as the firmware version with a “Last Updated” time of 2 May 2014 17:10:54, which was about the time I received the reply for support.


(Cory S) #12

I had one switch that did this a lot. Resetting the “breaker” built into the front of the switch would usually resolve the issue.


(Jam Dawz) #13

I’ve had this same issue with in-wall switches and outlets on a continual (weekly) basis. Supports solution: flip the breaker. It works every time, but gets old!


(Gilbert Chan) #14

I’m having a similar issue with a GE appliance module. Two out of three of them in my house consistently stop reporting the switch status. I have to unplug the appliance module and replug it in. Today I unpaired and repaired it, let’s see how it goes.

This was never an issue before, I’m afraid this may be a bug recently introduced. I’m working with support on this, so I’ll report back if I have reliably solved this.


(esung) #15

Adding my case here. I am also experiencing switches and plugs (z-waves, quirky pivot strips…) showing status incorrectly a lot more recently.


(Rusty) #16

I’m having the same issues this past week. First just one outlet switch, now I have a second one. I can operate them from the tiles, but they don’t respond to any apps.


(Lfschwartz) #17

Same here as well I have 3 switches that keep forgetting. They also show no events for the last 3 weeks, even though I’ve been trying to turn them off and on all day with little success. They are all GE/Jamco switches. My other z-wave devices are fine. I also tried the repair z-wave utility, but that did not fix it. I’ve emailed support.

Since October my entire system has worked perfectly and nothing has changed except the recent hub updates and now nothing works. Lights don’t run on schedules, etc. My wife is very frustrated as she just wants it to work. SmartThings has taken a big step backwards with the latest software updates.


(Derek Brooks) #18

UPDATE: Everything I said in the following post was a lie, lol. After looking behind the couch, I finally realized that the modules I’m describing are actually Smartenit ZBMPlug15 - Model 5010Q Zigbee plugs.

A year and a half later, this seems to still be an issue.

I have a couple GE 45602 smart, z-wave power outlet modules.

They worked great for a while, but now SmartThings seems to periodically forget about them… I lose the ability to control my lights, SmartThings sees a “new” sensor, then I have to delete my old sensors from SmartThings and re-add them.

Which obviously defeats the entire goal of convenience that I’m going after. :slight_smile:

I’ve reached out so support and will update with their response.


#19

Why don’t you reach out to GE/jasco as well and see what they say? You will see reports of the same problem in forums of other controllers, such as vera and Homeseer, all just with this brand of switch. It doesn’t look like it has anything to do with SmartThings.


#20

So I have a GE Switch in my Kitchen. Then, the device “Kitchen Lights” disappeared. Hmm weird. So I readded the device with the name “Kitchen Lights 2”. Few days later it disappeared again. My Echo integration with the Kitchen Lights is jacked up now because no matter what I try Echo keeps finding both “Kitchen Lights” and “Kitchen Lights 2”. Even though they are not listed in the “Amazon Echo” smart app. I also manually “forgot” them in the Alexa app. I noticed in the ST IDE under the “My Hubs”, both devices are still listed. It shows the device as Removed. There is a “Delete” button on the bottom of the page. However, that generates the error, “Device still in use. Remove from any SmartApps or Dashboards, then try again”.

  1. Any thoughts on how to Force Delete the device?
  2. What in the world is going on?

My Hub version is 000.014.00032