[ST EDGE] Securify Peanut Plug

Finished work on the Securify Peanut Plug with power monitoring.

Note that your plug will need to have its firmware updated (using the Almond router/hub, available cheap on eBay) before power/voltage/current values are sent.

If you’re interested in trying it (consider it in beta just like the rest of the Edge drivers), please sign up here:

  1. Use the invite CStup Edge Driver Invitation
  2. Enroll your hub
  3. Click “Available Drivers”
  4. Click the “Install” button on Securify Peanut Plug
  5. In the mobile app, pair your device using + Device → Scan for nearby devices
  6. Press and hold the reset (smaller) button while plugging the unit in. Hold until the LED starts blinking, this will force a reset/join. The LED will continue blinking to indicate its pairing.
  7. Device should be added within 30 seconds.
  8. If this driver was useful to you, maybe you’d like to buy me a coffee.

Power reporting is adjustable with minimum and maximum time between reports, and delta values for each of power, voltage and current.

There’s a lockout adjustment that will prevent the unit from being turned off remotely. I use these plugs to monitor power of devices I never want to accidently turn off (deep freezers) and this helps prevent that.

Please let me know any questions or suggestions!

6 Likes

Is this still in beta or is your edge driver official? I have some of these plugs and am currently using the GitHub driver for them. The power reporting has never worked properly, but as long as I can turn them on and off using ST and Alexa, it would be great.

They’re still as beta as all of Edge is.

Now that I have enrolled my hub and installed the Peanut driver, how do I use it? I currently have several Peanut plugs which I have been using for a long time with ST using the old GitHub DH.

Do I have to reset the Peanut plugs and readd them to ST? Will the DH I am currently using be ignored and the Edge driver be used?

The DH I have been using never correctly reported power usage.

To replace existing DTH backed devices, you have a couple of options:

  1. Delete the existing device and pair the device again. Deleting will remove any routines/smartlighting you have where the device is the only trigger or action. Some people will create a virtual switch to use as a temporary, editing routines to use the virtual instead, deleting, then switching the routines from the virtual back to the new device once its added.
  2. Wait for Samsung to auto-migrate devices. If you have the Edge driver with a matching fingerprint installed, when they migrate your device it should move to using it cleanly, including updating routines.

There is no “force migrate” option, unfortunately. I personally have been doing both options above depending on how complex the routines that support them are.

If you choose option 1 above, yep. The DTH being used should be ignored and the Edge driver take priority now. (they recently changed the priority order of driver selection, now that DTH’s are no longer able to be edited in the IDE.)

A couple things on the power reporting:

  • The firmware that shipped with the device never reports any power. You’ll need to update the firmware using either the Almond router (they used to be cheap on eBay) or do the update yourself using a zigbee stick.
  • The DTH that most people used had to estimate the power usage as the device itself doesn’t actually keep track of power over time. It only does instantaneous reporting and the driver would make a best guess. My Edge driver doesn’t try and do any of that as it wasn’t accurate, it only reports power, voltage and current. Current isn’t displayed but its being captured.

Good luck!

Thanks for this driver. I’ve got two Peanut Plugs. Neither was ever updated to add power reporting. After removing and rejoining one of them I discovered there seems to be no support in the stock Edge drivers.

I’ve successfully added your driver and rejoined one of my plugs. It’s on your driver and working normally.

But when I open the device details page in the app I see a pop-up “Couldn’t get device’s status”. Is this anything to worry about?

Which element on the details page has no data or the cloud icon in it? That’s the element it thinks isn’t reporting.

Voltage.

Settings are all at the defaults

It may be a bug. You have power reporting disabled (0 minutes for each), but power reporting sent a value (or maybe I send a 0W default just to initialize).

Turn reporting on to some non zero value and voltage should report. I’ll look at the code to see what’s up.

[update: yeah its a bug. If you never configure power reporting, the device will get power (W) but never voltage (V) on a refresh or initialize. The power fetch was being done by default, I just need to add voltage.]

Sent out an update to fix some of the issues I’ve identified. Wil update within 12 hours to any hubs subscribed to the channel.

2022/12/26 - V0.92 - 2022-12-28T15:58:42.260595216

  • Fixed issue where the driver wasn’t requesting the correct
    power/voltage values if monitoring was disabled.
  • Fixed issue where the reporting schedule was not configured
    properly if the driver reinitialized.
  • Fixed issue if the driver was changed to another driver
    and back to this one, the reporting and divisor data was
    not properly setup.

2022/12/23 - V0.91

  • Added single decimal point rounding to power and current values.

This should fix your issue, @HalD.

Thanks, @csstup Corey!

The error I was seeing is no longer popping up. The voltage shows 0.0v

All good!

1 Like