[ST Edge] Schlage 469 Lock Gets Associated as "Z-Wave Device"

I have an Schlage Touchscreen Deadbolt (BE469 CAM 625) that was working just fine until SmartThings transitioned over to Edge. It wasn’t working so I removed it from the Z-Wave network using the proper procedure (put the hub in exclusion mode and followed the manufacturer’s instructions for removal). Then, once I confirmed it was excluded successfully, I factory reset the lock and then attempted to re-add it. However, the device keeps getting added as a “Z-Wave Device” that does not allow me to change the driver to a Z-Wave lock or any other type (pressing the three … only shows “Edit” and “Information”, no “Driver”). I have repeated the process 7 times with the exact same results. Anyone have any ideas? I also tried using the drivers @philh30 created and I still get the exact same result.

Please help; I really need to be able to unlock my door remotely! Thanks in advance!

I’m sure that’s very frustrating. :disappointed_relieved:

This forum was set up a number of years ago so that customers could help other customers, but we’re limited in what we can see when things are being really weird.

Someone here may have a suggestion that will help, but meanwhile, you may want to go ahead and contact official support since they can see more things from their side. That’s especially true for anything regarding the official transition.

Their contact information is at the bottom of the following page

@Brannon-Z When you say that you confirmed it was excluded successfully, is that from within the app only? Have you checked in the IDE that it also was deleted there? I’ve had it happen when I was removing a device that it said successful, but still showed up in the IDE. This was before Edge stuff, but worth a shot.

1 Like

Thanks so much to both you and @JDRoberts . I just tried what you suggested Allan, but no luck; confirmed the device is removed from the list using CLI then re-added it… and it still shows as a generic Z-Wave Device. I appreciate the suggestion though, and will try reaching out to SmartThings support.


My experience says that this device is not pairing properly and when you look via the CLI, IDE, or API Browser+, it will show a fingerprint of all zeros and still using a DTH driver instead of Edge.

Is it a BE469ZP that needs to be set up with S2 security properly?

1 Like