[ST Edge] Personal Tuya Devices - Generic EF00 Device

I updated to the beta version but it has the same issue. Let me know if there’s additional data I can send you to assist.

Are you using wifi hub ?
This driver requires firmware 45.1+ to work properly.

I tried to enroll my hub and I got this error message. Any help would be appreciated

5 posts were merged into an existing topic: Unable to join channels (25 Jan 2023)

1 Like

It’s a platform error. It’s not affecting all drivers or all users, but it is affecting a lot of both. Reportedly fixed about 10 minutes before the time of this posting. See the current active discussion thread:

Unable to join channels (25 Jan 2023)

1 Like

Hi there @w35l3y, thanks for all your fab work on this generic edge driver.

I am new to SmartThings, and wanted to add a smart TRV to the SmartThings - The device is branded as Aubess _TZE200_hue3yfsn

Using your generic driver I can get the following information about the device, it looks like it is using the EF00 cluster.

So… I have taken your driver, and then tried to add my own model with the view to controlling it as a thermostat in ST following your instructions here;
EdgeDrivers/personal-tuya-devices at main · w35l3y/EdgeDrivers · GitHub,

I copied and edited _TZE200_znbl8dj5 as it says it’s a thermostat, and added my device details to the fingerprints file.

But… It installs and recognises the devices as a thermostat, but when accessing it in SmartThings it says “The device hasn’t updated all of it’s status information yet, check again later”.

Must have something wrong, could do with some pointers on how to get datapoint 16 for example, which I know is the temp setpoint to map back to a thermostat temp setpoint in Smartthings.

Any help would be much appreciated, sure once I have the first datapoint working I will be able to work through the other ones, comfort temp, window detection etc on my own.

Thanks in advance.

1 Like

You don’t need to modify fingerprints manually.
It is done by a github workflow that is executed automatically when you push the file to the repository.
It creates/modifies some required files.

You probably are receiving an error message in the log saying the file models.TS0601._TZE200_znbl8dj5 doesn’t exist.

If you want to test it locally, you’ll need to execute:

npm install
npm start

It will execute the steps needed to generate some files automatically based on your new file.

It may happen for 3 reasons:

  • The required files weren’t created properly;
  • You are using an existing profile that refers to a capability that you haven’t defined in your file;
  • The device didn’t send message with the datapoint you defined in your file.

Also, everytime you modify your model file for your local tests, don’t forget to execute npm start.
Otherwise, it will make you insane.

1 Like

Hi @w35l3y
I have bought a presence sensor like @X0mbie .
It pair and sync to the presence sensor but presence don’t work at all , lux work good.
Here the fingerprint

Thank you

This is not the screenshot of the driver I developed.
It doesn’t contain the minimum informations needed to give any assertive answer.

Sorry , there a screenshot from your driver .

Thank you

would it be possible to make something like this for wifi tuya devices?

This device is already mapped.

Was it not detected automatically as presence sensor?

Even though you haven’t sent the screenshot of the whole page, datapoints seems right. It should work.

I don’t have any wifi tuya device, but they don’t work the same way.
The concept of clusters is used in zigbee devices.

I don’t know how they communicate using wifi.
Probably, each device acts as client to send its states and as a server to receive its settings.
But this is subject enough for another thread.

I ad to pair it again like 5 times before it work.

Thank you

1 Like

Thanks @w35l3y for your work on this driver. I have used this for a Tuya garage door opener once I figured out my device was using cluster 0xEF00.

Device is listed as below, and your Garage Door profile does the trick.
Mfg Code: _TZE200_nklqjk62
Model: TS0601

Nice work!

@macazzlst…do you have a link to where I can purchase this zigbee garage door opener? I’ve been looking for one that’ll work with an Edge Driver.

Did you mean “Garage Door” profile ?
If so, then it is working for similarity with _TZE200_wfxuhoea which uses datapoints 1 and 3. Nice!

But if you really meant “Door Control” profile, then I would need the datapoints you used.

A screenshot would be welcoming.

@w35l3y - sorry, I was playing with this quite a bit and indeed I did use the Garage Door profile.


@Robbie.bushell - I suspect there will be many which work with this driver, but the one I got was: “Tuya Smart ZigBee Garage Door Opener Controller” https://a.aliexpress.com/_mLkY982.


I’d seen a number of people looking for edge drivers for various garage door openers, but since it seemed nobody had anything working I was going to buy one. Once I got the device in hand I was starting writing my own driver, until I found this thread!


That is probably because it was not paired with this driver.
At least the screenshot you sent is from another driver.
Make sure to select the driver “Personal Tuya Devices - main” from the Driver menu.