[ST Edge] Issues with released Drivers

I wouldn’t even think to look at the logs when pairing most devices. No, I use ‘silent’ to mean that the app didn’t display the usual tile inviting you to rename the device.

Neither did I get notifications from the Alexa or Google integrations of a new device, but Alexa has gone from actually being the fastest indicator of successful pairing to sending a notification when it feels like it, and Google has rarely ever done it at all. That’s another story though.

Just want to add a bit of context Graham, as you, I am in the UK and although I am not in any beta testing if I add any form of new device Echo picks it up instantly and reliably, although 2 different instances cannot be used as a yardstick there is a possibility that your specific network might be involved in some odd behaviours as you stated before

Echo not detecting devices is not systemic to all people

Which helps not a jot but does help the head scratching continue

The re-pairing mode used for groovy zigbee DTHs, which is putting the device in pairing mode without uninstalling it from the app and with hub unsecure mode, doesn’t work for edge drivers.
I also tried it, as says @orangebucket , and it pairs without the app showing that device has been paired and inviting you to change the name of the device.
From what was seen in the logs, it paired badly and did not send state events every set interval.
In order to It work properly again, it must be uninstalled and re-paired.

Yes, although my mention of a ‘silent’ pairing in this thread wasn’t in this context, I have found exactly this. I’m pleased to see it wasn’t just me.

As I raised the issue in another thread I’ll repeat it here for visibility.

In my case I was trying to re-pair a motion sensor that was reporting offline and did seem to be genuinely unresponsive for some reason. In my case I wasn’t watching the logs and nothing appeared in the app, but the device ended up marked as online. In fact the device was still in pairing mode.

With the interpretation of the metrics of the zigbee signal received by the hub, it is not known whether it is a direct device-Hub connection or through a repeater.
In screenshot that I send you, the log says lqi: c8 (200) and rssi = -50.
In this case I am sure that it is through a repeater that is between the sensor and the hub, since these values are impossible at a distance of 12 m with walls.

Will a more complete report of metrics by device be seen in the future, similar to the current IDE?
It is a very useful tool for the investigation and solution of network problems

The smoke sensor today started showing “Searching …” on the tile even though it is perfectly on line.
In STHM and on its details page it shows the correct status

drivers use obsolete math.pow function

ERROR Zigbee Motion Sensor Illuminance Sensor thread encountered error: [string “st.zigbee.defaults.illuminanceMeasurement_def…”]:33: attempt to call a nil value (field ‘pow’)

Thank you, @veonua. This is already reported as it was also included here:

I have seen It now.
In the status monitor of the favorites page, app android, the door open warning of the multipurpose sensor that has the edge driver installed does not appear.
With the DTH it did appear.

Yes, those options are not included in the local execution yet. Our team is working on that but there’s no ETA yet.

I can’t see the logs yet due to the below error which I have raised on a related thread, however I think this may be the reason why my Xiaomi illuminance sensor does not produce any readings using the zigbee-illuminance-sensor driver

None of my IKEA motion sensors should have gone active for a couple of days now. That hasn’t actually stopped some of them (grrr …). Three with Edge drivers have gone offline. I’m pretty sure those are the ones that haven’t been activated.

Mind you if they are relying on battery reports to stay online all bets are off as I have too many Tradfri Outlets around to muck things up. On reflection everything I have from IKEA is actually letting me down.

1 Like

Hi, Graham. Thank you for sharing the behavior of the devices, I’m checking some details with the engineering team so, I’ll get back as soon as I get their feedback. Thanks!

7 posts were split to a new topic: [ST Edge] Zigbee Illuminance Measurement

Back home now and all my motion sensors are online again without my doing anything. I’d like to think it was the motion events that put them back online. Recovering from being offline is great but I’ve yet to figure out what put them offline to start with.

Just pointing out that the ocf device type for illuminance sensors never had an icon so that’s not a new issue.

Just tried the Sonoff SNZB-04 contact sensor, which identifies as the eWeLink DS01, with the Zigbee Contact driver. Initial reaction is open/closed looks fine but there may be issues:

  1. It looks like the profile being used includes the temperatureMeasurement capability. I’d be delighted if it did support that but I don’t think it does.
  2. The battery level with the DTH was 60%, which sounds reasonable, but the Edge driver is reporting it as 3%. OK, the second one I tried had 74% in the DTH but is showing 69-70% in Edge which seems fair enough so I changed the battery in the first and tried again and got 100%. So that is probably OK. No wonder they are practically giving these things away at the moment.


  1. One of my devices that had been open since about 14:30 was showing offline when I just looked (about 18:30). Closing it brought it back online.

The Sengled and at least one of the Nyce contact sensors in that driver don’t support temperature either. I’m surprised there isn’t a sub-driver without temperature capability.

I believe this is the fingerprint that the “Sengled” device matches, right?

contact-battery-profile only includes the contact and battery capabilities, does the temperatureMeasurement tile appear in the device UI?

Do you know which is the other Nyce device that doesn’t include this capability, @Automated_House?

It’s different from the profile used by eWeLink DS01, which indeed includes the temperatureMeasurement capability. I’ll report that, @orangebucket to see if there was an error assigning the profile.

The Nyce one is correct. I missed the different deviceProfileName set for it. Thanks!

1 Like