[ST Edge] Issues joining device with a driver

I was able to discover my mouser with the edge driver, but it doesn’t work at all

Hi, @mvevitsis! I created this new post to discuss the issue further. When the device is joined, do you receive any errors in the Hub logs?
These are shown executing the CLI command: smartthings edge:drivers:logcat

Which of the released drivers are you using?

I was using the edge zwave mouse trap driver.
When I join the device using the groovy driver it works fine, but when using the edge driver it doesn’t load any data as shown in the screenshot above.
I’ll try again while running logcat.


I tried running logcat, but get this error. The CLI is the latest version, download directly from the GitHub. As for the IP address of my hub, this was verified from the Groovy IDE. Do I need to specify a port? I’m using SmartThings Wi-Fi.

As commented here, I’m checking some details with the engineering team regarding this behavior. I’ll let you know more as soon as I get their feedback.

For what it’s worth, I tried specifying a port and that didn’t work either (9495)