[ST Edge] EDGE_CHILD devices lose connectivity

Thank you for the info, @jds13.
Can you share the name of those devices, please? I thought they remained to be QS1 and QS2.
It can be through a DM

QS1 = “Desk”
QS2 = “Floor”

1 Like

Thank you, @jds13, I already created the report for the team about this. Once we get more info, we’ll let you know.

2 Likes

Hi, @jds13
Following up on your case, the team mentioned they need your help by reproducing the issue, this means:

  1. Remove the device, and its children (to “start fresh”)
  2. Re-add the device
  3. Switch drivers as you previously did

This is because they enabled more logging in the Hub because they need extra information.
Please, let me know when you finish.

At 11:50 PST I removed Qubino Switch 2 (Floor) (No confirmation required)
At 11:51 Next I removed Qubino Switch 1 (Desk) (It took two tries of triple-pressing button 1)

At 11:53 I added the device. Two devices appear. Shortly afterward I switched the driver on Qubino Switch 1. I now have two Qubino Switch 2’s - one in the room where I added/switched the driver (“Downstairs”) and the other in “No Room Assigned.”

I sent the logs.

To be clear: the problem I was reporting wasn’t about switching drivers. It was that the second relay - Qubino Switch 2 - “Floor” - stopped responding to hub commands after a while.

@nayelyz
I have the same problems with Neo Coolcam double switch, and described it in here:

as I haven’t seen this topic before.

Yes, we have this in mind, but reproducing all your steps with the new logging enabled can provide more info about what caused the device to stop working.

1 Like

Hi, @btrial. Sorry for the delay.
I checked your description and I need the following details, please:

  1. which driver is the device using?
  2. Do you know the fingerprints of the device? This is to know which device profile is assigned to it.
    There are two double-switch Neo Coolcam devices: SmartThingsEdgeDrivers/fingerprints.yml at main · SmartThingsCommunity/SmartThingsEdgeDrivers · GitHub
  3. Access to your account to see the details of your devices:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

Hi @nayelyz

  1. the driver used is edge “zwave-switch” from smarthings edge beta channel,
  2. the fingerpring will be this one:
  • id: 0258/0003/108B
    deviceLabel: NEO Coolcam Switch 1
    manufacturerId: 0x0258
    productType: 0x0003
    productId: 0x108B
    deviceProfileName: dual-switch
  1. “Account Data Access” granted.

Hi @nayelyz
Any update so far ? Or is anything else needed from our side.

1 Like

My Qubino EDGE_CHILD switches just started working again. Thanks!

Sorry for the delay, @btrial, the team mentioned they made a modification for the issues with child devices being unresponsive after a while. So, they should be working now, if you still see issues, please try to install the device again and let us know your results.

Thank you for the feedback, @jds13 :smiley:

1 Like

Hi @nayelyz
Yes, all devices work fine now and they don’t loose connection. But the main switch still shows child “Switch 1” element even though it is not usable here. It is not a problem though from usage point of view.

Hi @btrial

If you use Android App that should be solved by clearing the cache of the app

Yes I am on android, but neither clearing the cache nor the whole storage helps.

In fact, it was not corrected because smartthings forgot to delete the switch1 component in the dual-switch profile or create a single switch profile for it.

name: dual-switch
components:
  - id: main
    capabilities:
    - id: switch
      version: 1
    - id: refresh
      version: 1
    categories:
    - name: Switch
  - id: switch1
    capabilities:
    - id: switch
      version: 1
    categories:
    - name: Switch

@nayelyz
Could you escalate it to developers to fix.

Thank you for looking into it, @Mariano_Colmenarejo.
I just shared that with the team to know who can help correct the profile.

1 Like

Hi @nayelyz
Not sure what developers have done but today all my double switches (Neo coolcams) started to work totally wrong. Problems:

  1. In the main component the child 1 element haven’t got deleted as we requested but instead it shows working main and child1 elements:
  2. The child component is also present as following:

    but it doesn’t work any more.
  3. when I try to enable child component from point 2) then main switch enables instead child one. Enabling child1 is only possible in main component.

I tried to exclude and include NeoCoolcam double switch again from smartthings and it doesn’t add as Edge driver any more but with standard DTH “Z-wave dual switch” and “Z-Wave Binary Switch Endpoint” for child component instead.

I have observed exact problems also for Qubino double switch. Same scenario as for Neo coolcam double switch described above and readding it does not solve a problem as groovy DTH is used instead edge driver.

So I believe the problem must be with Z-wave switch driver in general as new version have been updated lately:

No problems at all with my Qubino Flush 2 relay modules in two weeks of regular usage. Both sides work fine with Switch 1 a ZWAVE metering-switch and Switch 2 an EDGE_CHILD metering-switch.