Child Devices Missing

My Smartthings has been pretty stable for quite some time so other than the original changeover to Edge drviers etc, I haven’t touched it for ages.
I have a few Zigbee dual switches. Haven’t had any issues, but a couple of weeks ago, one of the channels on one of them stopped working. Nothing I did would get it to work. The ohter channel worked fine. App wouldn’t connect to it. Eventually I removed the device and tried to reninstall it. It couldn’t find it at all then.
I am using the Zibee Multi Switch and Child Mc Driver
I assumed the switch was faulty so I bought a new one. I could add the new switch, but the child would not show up.
My other dual switches were working fine.
Now all the second channels (the Childs) have stopped working.
I have probably just forgotten how to work everything or it’s different and I can’t use the new style.
Anyone able to help?

Edge drivers with the suffix Mc are usually the work of the amazing @Mariano_Colmenarejo . Usually the first thing to do would be to check his author thread for that particular edge driver to see if others are having similar problems. :thinking:

(EDGE Driver-Mc): Zigbee Switch Mc, Zigbee Switch Power Mc, Zigbee Multi Switch and Child Mc

Also, it would be a good idea to go to the official Web UI to your SmartThings account and check to see exactly what edge driver the device is using and what its “fingerprint“ is.

Samsung account

1 Like

Hi @lee_ness

In my driver, child devices must be created optionally from the preferences settings.

Child devices in the stock driver are created when the device is paired.

Child devices that are created with one driver do not work with a different driver. That is, if they were working with the stock driver and you changed to my driver, then the child devices you had will not work and you will have to delete them or return to the stock driver.

If the device is not paired with drivers, then fingerprints, as @JDRoberts says, may not be identical on the two devices.

Publish the fingerprints from, advanced users or install zigbee Thing Mc driver on your hub from my channel and pair it to see all the data of the double switch


I think this is correct for the fingerprints.
I can see the main switch and switch 2 in the mysmartthings entry under attribute but not in the app.I can even switch it from in mysmartthings if I open up the device.


  • deviceId: “6d5697a1-7a24-4c45-bdbb-fca64d7b27fa”,
  • name: “single-switch-plug”,
  • label: “Side Light 1 1”,
  • manufacturerName: “SmartThingsCommunity”,
  • presentationId: “f1f98ed4-5007-3591-bd63-2a77df7ae398”,
  • deviceManufacturerCode: “_TZ3000_pmz6mjyu”,
  • locationId: “dd0c54f3-2777-4b5f-a134-9ef65987dcd5”,
  • ownerId: “17fb18ad-9fc7-c42c-dd5a-64459358de5a”,
  • roomId: “160b8ab1-4b64-4584-b031-4b4c0f382ea4”,
  • components: [
    • {4 items},
    • {4 items}],
  • createTime: “2023-11-01T18:26:28.196Z”,
  • parentDeviceId: “fd231048-58e6-4107-9178-222580f8d9e9”,
  • profile: {
    • id: “2819525c-0595-3e2c-853f-91bcb1583174”},
  • zigbee: {
    • eui: “F4B3B1FFFE601856”,
    • networkId: “E863”,
    • driverId: “e9bfd289-1d51-499e-8c64-d564d1868ad2”,
    • executingLocally: true,
    • hubId: “fd231048-58e6-4107-9178-222580f8d9e9”,
    • provisioningState: “DRIVER_SWITCH”},
  • type: “ZIGBEE”,
  • restrictionTier: 0,
  • allowed:


Have you checked App’s all rooms?
You can also select from App’s Room selection All devices.

Yes. It sin’t on there and it isn’t on the mysamsung list on the browser either, but as I said, it does show up in attributes.