ST app some what not working

Hello everyone, Wanted to see if anyone else is having this issue. I noticed on 4/1 that I was not able to access any of the advanced options for my devices i the ST app. When I click on any device in the ST app it says Downloading… followed by an error

What’s interesting is the app is some what working. The kitchen light for example. If I tap on the power button icon it will turn the light on or off. Same is true for other devices. I can also control every device with my smart speaker. I’ve tried power cycling the ST hub, router and cable modem. Thinking the issue was with my Android phone I tried installing ST on an IOS device and it had the same issue. Last time this was working correctly was on 3/28. I had changed a battery on one of my sensors so this broke sometime after that.

Anyone else having this issue or suggestions on what could be going on?

Hey there! @Bossman302, I noticed you were having trouble on another thread as well as here for what seems to be a cache issue.

Android: Have you already tried clearing the cache for the Smart Things App, Restarting your device and seeing if the symptoms persist?

Settings>Apps>SmartThings>Storage>Clear Cache and Restart your device.
Note: Clearing the Data of your Smart Things App, will require you to re-organize your home screen setup for the Smart Things App and you may have to re-accept permissions.

Does the symptom persist? If the symptom does persist, I would recommend creating a Support ticket so we can look into your concerns further.

You can reach out directly to a support team in your area using the below information:
US: 1-866-813-2404

I hope this message finds you well!


@nathancu, those support agents seems to be not listening at all…

@Bossman302, do you have anything on your network like Pi-Hole or anything installed on your device which would block things?

If you do, then have a look here:

The other issue could be also, if you recently updated to Android 11. Some people reported issues previously regarding downloading device UX plugin.

Hello @SamsungZell ! Thanks for responding. I’ve cleared the cache many times but never followed with a reboot of the device. Went ahead cleared the cache and reboot but still didn’t resolve the issue.

Hey @GSzabados! I don’t have anything like that but I do have an Asus router running the Merlin firmware. I also have a VPN running with Diversion for AD blocking. I did try shutting both the VPN and Diversion off but still no luck. You got me thinking though… Realized I never tried turning off wifi on my phone and tried using Smarttings over the cellular network. Went ahead and did so while typing and… I selected the Kitchen light and received a prompt an update was needed. I got this before while on wifi but it never did anything. This time while on the cellular network I hit update and i’m now able to get into the kitchen light options. All my devices now work both on the cell network and my home wifi network. Guess there was/is something screwy with my home network. Either way thank you for your input and getting me back up and running!

1 Like

In that case it can be a DNS issue as well. But it’s good that you managed to get things running.