New Smartthings app issues when using Pi-Hole

Since the classic app was no longer supported, I have been having issues with the new IOS app. When I access the app through cellular (wifi turned off, thus pihole not being used) the application works fine.

Here are the issues I am facing:

  1. When trying to add a new device, “by device” or “By Brand”, the application returns with nothing listed

  2. When accessing the hub, the connected devices will not show

  3. Widgets can not be accessed

  4. When trying to turn on location tracking for my phone, when I activate (slide right), the app immediately moves it back to left (not activated)

  5. Smartapps do not function (all, but most of all Smart Lock Guest Access SmartApp", receive “Server error occurred” “Server isn’t responding” on home screen

As I stated, when I turn off Wifi, I have no issues with these functions

I have added the following sites to the Pi-Hole whitelist but the issues continue to exist

To try to find what other domains Smartthings are trying to call, I am monitoring the Pi-hole query log when I am accessing the app through Wifi and see no other domain denials to add to the whitelist.

Anyone have any idea how to resolve this? While I can get around turning off wifi when I add new devices, the SmartApp server problem makes any usage of Smartapps useless as long as I am on my wifi


I think @jkp had a lsit of domains that need to be white listed


Is that a typo?

Should be

1 Like

I had both in my whitelist and

In the past, it was basically the url but for a few, was needed. If you discover another domain needs to be whitelisted, report back for other users who might encounter the same issue.

I have added to the whitelist, but the problems persist. Is there other URL’s that Smartthings use, like when adding a new device when it needs to provide a list of brands?

Why www? Just plain

Not that is it will really matter :slight_smile:

I did change it to and also added the domain as a wildcard (so subdomains would be included) but that did not resolve anything :weary:

what about ?

Thanks, tried that and problem persists. This is especially frustrating because normally you would see the domain blocked in Pi-hole, then can whitelist it, but nothing appears to be blocked on the query list.

When I go to add a new smartapp, it comes back with “no items”. Another peculiarity is that when I disable Pi-hole, the problem persists, but works as long as I am off wifi. My Iphone has no firewall or filtering software on it. I have UFW running on the Raspberry PI that has Pi-hole installed, I have disabled UFW but that has not helped towards a resolution. So not sure what else could be impacting the ability for SmartThings to work correctly

Does anyone have an update for this?
I’m having very similar issues too!

More details. What steps noted above have you tried? If you turn off wireless on your mobile device and use cellular only… do the Smartapps show?

Hi. I did follow everything above adding the URLs listed and somemore that I’ve found myself. I think it was more down to my mobile not clearing it’s DNS cache even after restarting my phone a few times.
All is working now though.

Thanks @jkp for a super quick response.