ST + Aeotec Hub V3 + Matter + Hue = Problems

Since yesterday I have the Aeotec V3 Hub and SmartThings running on an S24. Setting up the hub also went smoothly. I am new in ST - came from Apple HomeKit.

I wanted to connect Philips Hue to ST or the hub via Matter. That also worked and all devices such as lamps, sockets, sensors and switches were displayed in ST. In total I have around 45 devices.

The problem, however, is that not all of the devices can be switched. The sockets e.g. could not be switched at all. Not all lamps could be switched - only some.

What exactly could be the problem here?

I’m sure that’s very frustrating. :rage:

The matter integration is very new on both sides, so there have been some occasional glitches. I’m not sure if that’s what you’ve run into or not.

Can you give us the specific brand and model of one of the sockets which is not working?

Also, have you checked to make sure that the firmware is up-to-date on both the Hue Bridge and your Aeotec hub? Historically, that’s been the most common reason for a Matter integration to fail.

To be honest, most people in this community are not using matter for a Hue bridge, because there is a native SmartThings/Hue integration, which is already local, and already works quite well. It doesn’t bring in all the attached accessories, however, but there is also a community – created custom integration, which does bring in even more features than the matter integration does. So you may have to go through official support to see what’s going on (I would start with Phillips, hue support, myself) but maybe someone here will know more. But it will help to know one of the specific devices which is failing. :thinking:

Tagging @jkp

1 Like

Is your Hue setup linked via Matter to anything else? You mentioned Apple HomeKit as a possibility. My understanding is that the multi-admin portion of matter is very poorly implemented. If you have other ecosystems, you may want to pick one. To echo the comments from @JDRoberts above, I would just avoid it altogether though. Hue has one of the most stable and well supported proprietary APIs. You get more functionality and don’t have to suffer through the growing pains of Matter. My driver for Hue is better if you are staying with SmartThings.

Jump to this post to workaround a recent ST breaking issue.


Thank you for your feedback and sorry for my late reply.

I set up the hub or the entire setup again. The devices are all there, but they cannot be operated from a standstill. The solution was to reload the device once in each device in ST. After that, the ST control also worked and the sockets switched. This also works with automations.

Overall, this seems to have solved my problem.

BTW: I also tried Legacy, but that didn’t help because only half of the available devices were displayed.

BTW2: I am not using HomeKit and ST in parallel. I switched completely. In terms of automation, I like ST even more than Apple Home. There is a lot more that can be set, which with Apple can only be done via shortcuts as a detour.

I use both SmartThings and HomeKit.

I just wanted to mention that for both platforms there are third party apps that allow you to create much more sophisticated rules for your automations.

For SmartThings, SharpTools is very popular.

For Apple HomeKit, Home+ 6 gives you a very broad range of automation elements.

Choice is good. :sunglasses: