Specific Time automations not working

I recently switched to an v2 hub. Since then, I have not been able to get any of my “specific time” automations to work at all. I have my outside lights set to come on at sunset and go off at sunrise, this automation works great.

I am not able to set an automation that uses a “specific” time constraint. I just try and test it by having a light come on at 8:00 pm and they never come on. I have emailed support with zero help. My location is set, so it’s not a time zone issue.

All I know is this is very very frustrating that thinisnt working. Any help would be great.

Login to IDE at https://account.smartthings.com and click on My Hub and look to see if your timezone and sunset/sunrise info is correct. If not, go back to the ST app, change your geolocation to somewhere in a different time zone, save, wait one minute, change back to your correct location, save.

1 Like

Same problem here but this method didn’t solve the issue. Not sure what else can be done. The timing isn’t even an option for me it’s just greyed out.

I am brand new and this is my 1st post. I had this issue setting up my 1st automation using a specific time condition. I am able to create the condition as long as it starts in AM and ends in PM. My desired condition started in the PM and ended in the AM.

When faced with something similar, I created two of the same automation, each with separate time constraints.

One with the condition sunset - 11:59pm and another with the condition 12:00am - 5:00am.

It’s a bit klunky but seems to work.

I would guess that this oversight will be fixed in future updates of the app.

I would be totally open to that but I am not sure how to workaround this limitation - say I want my motion detector to activate a camera between 10PM and 5AM - right now AM must come before PM which means I can only do: 5AM to 10PM wich is the time I do NOT want this automation to run - with Sunrise and Sunset I only have minutes before or after - I could use that if I had hours before or after since 10PM is hours after Sunset. Evin if I use at 9:59PM then next condition has to start with AM.

Check out webCoRE

Question. Are you using the new app (STSC) or Classic?

Two conditions, two rules.

10pm - 11:59pm &
12am - 5am

As @jkp mentioned, if you have WebCORE installed you can use that.

I am using the new app - I am not a developer by anyway shape or form but I am checking out webCoRE for the first time to see what it is and how I might utilize it without it being over my head and over my capabilities -

As I was typing my response I remembered there being issues using custom automations and “time” in the new app. In fact, I ran into an issue with it this morning. I don’t believe that it affects Smart Lighting though which is where is use the 2 .

Webcore will do everything that you want it to do. I have used it extensively in the past.
Once you get past the learning curve it’s very powerful.

Just a disclaimer on webCoRE- it can not control SHM status, location services or Samsung appliances and TVs in STSC.

I think he is trying to use the custom automation. I just keyed a rule in smart lighting and had no problem starting with a PM time and ending with an AM time.

@JOnesto949, How are you trying to create your rule?

You can use set times in custom automations. It is only when using sunset to sunrise where there seems to be a bug in STSC, even when using offsets.

“custom automation” using a Motion Sensor device - If within a specific date and time and motion is detected then alert me

Thanks. I knew I read you found a bug just wasn’t completely sure what it affected.

FWIW, the bug was still there. I have a rule with a “sunset-60 to sunrise” that fails. The condition was testing positive even after sunrise this morning.

I installed webCoRE- I was using Smart Connect (SC) app. It doesn’t look like I have access to webCoRE in the SC app? Do most people just uninstall the SC app and do everything from Classic or do you need both?

You will need the Classic app to initially set up any instances of webcore, after that you can use STSC. You can have both apps installed at the same time so there is no need to remove STSC. Just remember my disclaimer above about Webcore and STSC above.

Thank you JKP - I actually wrote my first piston and think I got around this Motion Sensor Specific Time Automation constraint. I used is between $Hour24 10PM and $Hour24 5AM. Just not exactly sure why I would need to keep both apps though after I registered? Does Smart Connect do something Classic doesn’t?

SmartThings (Samsung Connect) is needed to setup v3 or st-adt hubs and to install/control Samsung TVs and appliances. Plus there are some integrations only available through STSC.

I believe you should keep both apps installed. Eventually the Classic app will go away.

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.