Automation with Time based on sunset/sunrise not working

I’m having issues with automations set based on sunset/sunrise. I’ve set it up using the precondition Time so it only runs between sunset and sunrise (night time), this way the light only turns on during the night and when motion is noticed (device trigger).
They were working until a few days ago. I also noticed that the sunset/sunrise time is not in the IDE anymore, not sure if it was before this though…

Has anyone else noticed this?

Look in Locations and click on the name of your location…

Unfortunately it’s not there… I assume that’s why my sunrise/sunset automation isn’t working.
image

i have the same issue. Sunset/sunrise and time related automations doesn’t work anymore. I happened about 11hrs ago.

I’m in Brisbane! I wonder if it’s only related to Australian locations.

Please email support from link here about automations, I just did. https://support.smartthings.com/

Thanks, I did this and this is the response I got:

Dear SmartThings Customer,

Thank you for reaching out to Samsung SmartThings support.

I see that you are experiencing issues with the sunrise/sunset based automation in your account. I would apologize for any inconvenience this may cause.

Upon looking at your account, the timezone is reporting as Australia/Sydney and Samsung account registered under Australia region. I would like to inform that we are from SmartThings US support and we have limited access to Australia region accounts.

However, please note that the new SmartThings app no longer needs “Hello home routines” to fix the issue with time-based automation. Kindly reach out to Australia support team at www.samsung.com/au/apps/smarthings/ or report a problem in the new using the steps below:

Open the SmartThings app, tap menu
Settings
Contact us
Report a problem
This will submit a support request to SmartThings Support in Australia region.

Have a great day!

Best regards,
Raj
SmartThings Support
www.smartthings.com

I got this response:-
Hi Andrew,

Thank you for your SmartThings query.

Due to the COVID-19 pandemic, our team is currently operating at a reduced capacity. This means it’s taking us longer than usual to assist you with your query. We’ll be able to respond to your query sooner if you are willing to directly share your contact details and authorise a direct reply from our team.

If you agree to being contacted directly, please respond to this email confirming the below details:

• The registered email address of the Samsung account you use with SmartThings.
• That you grant us permission to access your account in order to resolve your query.*

If our team requires any further details to help resolve your ticket sooner, they may wish to contact you via telephone. If you’re happy with this method of contact, please also provide a telephone number in your response.

There’s a wealth of information available via the Samsung SmartThings page (Samsung SmartThings - For Your Connected Smart Home | Samsung UK) which might help resolve your issue sooner; just scroll down to the Support section (if you’re accessing via a mobile device, swipe right to see all support options) to access the SmartThings Community or our instructional videos. You can also find out more about which non Samsung devices work with SmartThings and learn about our latest features on this page.

If you’re new to SmartThings, you can access Virtual Home within the SmartThings App where you can try out key features and simulate the control of devices - without having to own them. To access Virtual Home, select the in app menu (≡) then ‘How to use’ and click the top banner.

*For more information about how we use your personal information, you can find our Privacy Policy at www.smartthings.com/uk/privacy. This may include using your personal data to provide support-related updates and assess and improve the way we support our customers, including carrying out customer satisfaction surveys.

Warm regards,

The SmartThings Team

Same issue here since yesterday. Time based automations are not working. If I remove the time criteria, then automation works fine. In my case automations utilize Sunset/Sunrise, etc… I tried rebooting the hub, but no help. In the IDE, I do see Weather Sunrise/Sunset and Time Zone set correctly.

Screen Shot 2021-07-28 at 11.08.08 AM

1 Like

Same here. Romania.

Same here, Belgium!

It’s working again for me. It’s now between sunrise & sunset in Australia and my routine started working for my test.
I’ve set it back to turn the light on between sunset & sunrise and motion is detected, will advise later tonight if it’s working.

I’m still not seeing the sunset or sunrise time in the IDE

Even before the COVID SmartThings Australian support doesn’t exist, they never got back to me on any of the support questions…

I can’t see sunrise and sunset in my location…

Me either, but I’m not sure it was showing before anyway.
My routine is now working during sunset to sunrise as expected.

Mine is working now again. However I’m still going to leave it at time based control just in case it stops working again.

Stopped working again since the afternoon of 10th August. I wonder if this is just me this time or entire Australia…

That’s odd. I’m based in Sydney and they’re still working today.

Back on working again over night!

Must be a location related issue I reckon. SmartThings stopped receiving sunset and sunrise data periodically in different locations and causing all the drama-_-