Sonos speakers not being discovered - New app!

Ok, try them one by one. Power the other ones down and go only with one first. And wait as much possible. If you haven’t migrated yet, you can try the same add device from Classic, might work.

To add any device, as my experience, it takes time to show up.

Any luck with this I have the same issue. I thinking because alexa and google working with them it has something to do with 2.4 and 5 networks. All my sonus are on 2.4 and smartthings is on 5. Classic app worked fine

I had the same problem. I could not connect the sonos after the migration to the new app whatever I tried. Today I manually connected them in the API-portal and now they are back in the new app.

Could you tell me how to do that manually? You created them manually and set DNI to their IP hexified? Also, what did you do for rooms that had multiple speakers paired - which one did you use the IP for?

I am also having this issue. My SONOS speakers cannot be discovered no matter what I do. My hub is a v2 hub. My speakers were working before the upgrade. Now they don’t. So I deleted them so I could reinstall them after the update. Now they cannot be rediscovered.

Same issue here. I noticed that announcements weren’t being made. Tried to remove and re-add that speaker to no avail; then noticed all my other speakers were offline.

Doing all of this from the new SmartThings app and the using web socket device handler. Originally migrated with no issue. All my speakers (13 of them) have reserved IPs and are otherwise working fine.

Any help is appreciated. Thanks!

I just clicked create a device. In the box device network id I just put in the ip-adress in plain text. For the type I choose Sonos. Added name and I tested it and it just worked.
If I knew it was this simple I would have done it a month ago when I lost the speakers from the app. I only have two sonos speakers yet and they are in different rooms so I don’t know how to connect paired speakers.

I tried this and still couldn’t get it to work. I tried the IP address for one of my players as well as the MAC address for the device network ID (DNI). My devices, when they worked, used the mac address as the DNI. I tried the “LAN Sonos Player Websocket,” “Lan Sonos Player,” and “Sonos player” device handlers and none work (although I believe we are supposed to be using the websocket handler as the other will be deprecated).

I can add the devices and they show as “online”, but nothing seems to work. It can’t read the current status (i.e., whether anything is playing), it cannot control my Sonos, and text to speech is not working. This is all from the new app.

I’ve been trying to fix this for three days now and at a loss. Like @schwark, I can see SmartThings detecting all of my Sonos players in the IDE log when I attempt to add a device, but nothing shows up in the app. Very frustrating because I widely used TTS notifications and none of that is working now.

Any other help/suggestions are greatly appreciated! Thanks!

Which device type did you use? Sonos Player or one of the LAN Sonos Players?

Hi everyone - Thanks for bringing this to our attention. We have identified an issue with our Sonos integration that may impact discovery, control and status updates of Sonos speakers for some users. Investigation is still ongoing, but it appears that there has been a firmware update to Sonos devices that changes the behavior of how we communicate with the devices via WebSockets. We’ve opened up an incident ticket with Sonos and will be working with them to resolve the issue.

From our initial investigation this issue may primarily affect users that have a large number (8+) of Sonos speakers added to a single Sonos household. Users with only a small number of speakers may not experience any disruption. Also, users that have a large number of Sonos favorites may not see the full list of favorites reflected in the device detail view in the SmartThings app.

If you are experiencing issues related to the above, please feel free to DM the following info:

  • Specific issue you are seeing (discovery, device control, status updates, etc)
  • How many Sonos speakers you have in your Sonos household
  • The build and version of your Sonos system. Can be found in the Sonos app via Settings gear -> System -> About My System.
  • Approximately when you first noticed issues with your Sonos devices in SmartThings.

Hang tight, we are working to get your Sonos speakers back up and running in SmartThings ASAP.

Barry

7 Likes

The only type I found in “Type”-list was “Sonos Player” so that what I used. I don´t know the difference between the types.

Based on what @BarryA said above, I figured out a temporary workaround to get at least a few speakers added. I unplugged enough speakers to get down to 7 in my Sonos environment. I then scanned for new speakers in the SmartThings app.

The seven speakers appeared and I was able to add. Great success! I plugged all my speakers back in, and it still appears I have functionality in SmartThings (although I have not tested thoroughly).

I hope this info helps everyone out as Barry and Sonos sort out the issues with the integration.

When you turned all the speakers back on, did it add the other speakers, or were you only able to add the first seven?

Only the first seven. All speakers work in Sonos, but only the seven I added in SmartThings are useable in SmartThings.

I tried adding the other speakers after the initial seven, but they go undetected (same as before).

I mainly use one or two speakers for announcements, so this will tide me over for a bit until they fix the integration.

At the transition to the new app status update was the issue along with control. I removed all speakers from my account. Now discovery is the issue. The app does not find any and they are playing music currently. I have 13 speaker in the house. I’m going to unplug all but 7 of them and try discovering again and user above did. I also had and issue with a switch with discovery and was able to add it with the classic app.

Sonos app version 12.1.1
Sonos OS. S2
6 Play 1s
1 Beam
1 Play 3
1 Play 5
1 Playbase
3 Sonos One’s

Update

Unplugged all speaker’s. Rebooted ST and router. Plugged in one speaker at a time and ran add device in smartthing each time. All was good 7 for 7 then number 8 added but sows off line. Then adding device would not find any more of the 13 speakers. Grouping of speakers does not work in smartthings although other controls worked

Hey all - We have a fix rolling out to our beta users tomorrow and then to production shortly thereafter. If you are not enrolled in the hub firmware beta and would like to get the update tomorrow, send me a DM by 7AM CST tomorrow.

Thanks again for your patience while we work through this issue.

Barry

1 Like

Up and running again using the beta firmware! Thanks @BarryA for addressing this so quickly!

1 Like

The beta firmware works beautifully - thanks for a quick fix… Now the only issue is that WebCORE does not recognize these speakers as a speaker capability. Not sure if that is something WebCORE needs to fix or something that is different about these speakers on the SmartThings side.

EDIT: Sounds like they show up in Refreshable devices in Webcore not in speakers. I am not completely sure if they will play via Webcore, but they are now added to Webcore as well this way.

1 Like

I’m not very familiar with webCoRE, but for capabilities the old, unofficial “Labs” Sonos integration that we migrated away from used the now deprecated Music Player capability. I believe webCoRE may be filtering on that capability. The capabilities the Sonos Player Websocket DTH supports are the following:

		capability "Refresh"

		capability "Audio Mute"
		capability "Audio Notification"
		capability "Audio Track Data"
		capability "Audio Volume"

		capability "Media Group"
		capability "Media Playback"
		capability "Media Presets"
		capability "Media Track Control"

The above Media* and Audio* capabilities are intended to replace Music Player. It allows developers to create integrations for devices that may only have a subset of the functionality that the old Music Player capability required. I’ll admit the migration from the old to the new had its issues, and we tried out best to transition all the existing Sonos devices the best we could. If there is a way to have webCoRE filter on the the core Media capabilities that typically define a speaker, for example Media Playback and Media Track Control, that should provide a good list of speaker type devices.

Barry

1 Like