Sonos discovery issue

Has anyone got any thoughts on why a Sonos play 1 speaker fails to be found by device discovery or through the by brand Sonos connectivity option ?

To confuse matters more, I have another play 1 of the same age and type that discovers fine, play 5s discover fine, in the Sonos app the play 1s are not set to stereo pair, they are named play 1 A and play 1 B

Play 1 B fails to be discovered

Currently at a loss on how to resolve the issue

have you tried to do a factory reset on the speaker

Not at the moment aweston because the speaker shows fine in the directly connected list, non of the directly connected devices are selected and are not included in the ST app

have you restarted the phone and/or the hub thru the ide

For Sonos, there used to be a trick to power down and up the speaker to help discovery. It stops announcing itself when there is a high mDNS traffic on the network as I can recall. (Like other speakers or Philips Hue, etc…)

Otherwise there used to be a bug when you couldn’t add more than X Sonos speakers. But supposedly, that has been fixed already.

Hey there! @fido, Give a try adding the device through the Supported device list by selecting your model code.

(+)Add Device>By Brand>Sonos>Supported Devices>One

Here is an example image:

Thank you for the reply @SamsungZell but as mentioned in the first paragraph of my first post this has already been tried and did not find the powered on and working play1 gen2 speaker

@fido, thank you for confirming that you indeed attempted to connect through the supported devices option.

I attempted to re-create your symptoms with your setup to no avail, I was able to factory reset, remove/re-add the two speakers to Sono’s App and they were re-added to Smart Things App as seen below. After setting up in the Sonos S2 App to my network the Scan Nearby option automatically detected it as seen below:

Are the devices located near your router for the best signal? Have you tried resetting up in the Sonos S2 app connecting the Play 1 device to ethernet and attempting to discover?

You can switch between the device network setup using the below steps:
Open the Sonos S2 app for iOS or Android.
From the Settings tab, press System > Network > Manage Networks.
Press Update Networks and follow the prompts to connect Sonos to your Wi-Fi network.
Once the wireless setup is complete, disconnect the Ethernet cable from any Sonos products wired to your router.

As I was able to add both speakers using all methods, I’d recommend reaching out to Sonos if the symptoms persist after a factory reset attempt. I wanted to provide you with their customer support information and product troubleshooting:
Sonos Support Fix an Issue.
1 (800) 680-2345

I hope this message finds you well!

^SamsungZell

That is a really good assumption, but @fido hasn’t mentioned that any of the speakers are on S2 firmwares.

He has Play:1 and Play:5 speakers. Only the Play:5 (Gen 2) has received the S2 firmware, the Gen 1 works only with S1.

And if you have any which is S1 only, it is a better choice to keep all of them on S1 if you want to use them together. As far as I know, you cannot mix S1 and S2 speakers in multi-speaker setup, if you want them to “Play” together.

https://support.sonos.com/s/article/4786?language=en_US

@fido, have you tried what I suggested?

Here is an old topic what can help also, but here to note it was with the old integration.

(Turning off other devices might would help you as well.)

Not really had time to deal with the issue in depth but I have tried a reboot of the stubborn speaker which still refuses to join ST

My system is S1 only, my bad for typing (gen2) above but either way S1 S2 gen1 or 2 the speaker should join without issue

Actually if your careful play5s are a good bet at the moment, they are known for a few issues after a few years but if you know a good repair shop cheap play 5s are a good option, I actually prefer the tone of play1s but can’t resist a bargain play5, originaly costing around 4 to £500 picking them up now for around £100 or less is a real temptation.

With regard to the stubborn Play1 that refuses to join ST, when searching for devices as a general search it is found along with all other speakers if I want a direct connection but I don’t want that, all my other speakers join ST no issue just this one odd Play1 that has been part of the system for years, its not like its just been added and they are all connected to a Sonos hub

1 Like

I will tag @BarryA. He might have some other ideas what to look for to get that Sonos Play1 connected.

Issue resolved
The Play1 speaker did not show up when adding devices because it had already been included into ST

The speakers inclusion name from the Sonos app had not been honoured, instead of the name listed in the Sonos app as Play1, it got included as ‘Kitchen’ which is where the Play1s used to be

So I am not completely sure which part of name changing and re adding went awry but once I had deleted all the speakers from ST and re - searched again, everything added correctly and the naming from the Sonos app was honoured

1 Like

Awesome news fido, Glad to hear you got everything up and running. Enjoy your Speakers :slight_smile:

^SamsungZell

1 Like

@fido, it is good to hear that all resolved.

1 Like