Sonos speakers not being discovered - New app!

I had the Sonos speakers setup via the Labs integration before, and then migrated to the LAN Player Websocket thing via the IDE when that change happened. I migrated to the new app, and the speakers stopped working via Webcore.

I checked the new app, and they show offline. They are most definitely not offline, as I am able to play music on them via Alexa, so Alexa is able to connect to them just fine.

I therefore removed the speakers, so I can re-add them. Unfortunately, now they are not being discovered by the new app at all!


Reboot your ST hub and your router… then attempt to add the devices.

Consider assigned IP#’s for your Sonos speakers.

Super LAN Connect on the IDE logs, seems to show them being discovered, but the app does not show me devices to add!

( 12:51:13 PM: trace addDevice evaluation: d: null, selectedDevice: uuid:RINCON_ XXXXXXXXX00::urn:schemas-upnp-org:device:ZonePlayer:1=

{data={ip= XXXXXXXXX, mac= XXXXXXXXX, manufacturer=Sonos, model=Sonos PLAY:1, port=0578, ssdpTerm=urn:schemas-upnp-org:device:ZonePlayer:1}, deviceAddress=0578, devicetype=04, hub=XXXXXXXXX-f884-4645-8d6a-XXXXXXXXX, installed=false, ipFixed=false, Mac=XXXXXXXXX, name=Den, networkAddress=XXXXXXXX, ssdpNTS=null, ssdpPath=/xml/device_description.xml, ssdpTerm=urn:schemas-upnp-org:device:ZonePlayer:1, ssdpUSN=uuid:RINCON_XXXXXXXXX00::urn:schemas-upnp-org:device:ZonePlayer:1, stringCount=04, verified=true}, dni: XXXXXXXXX

That is the SSDP URN it seems to be searching for and I see each of my Sonos show up in the logs. Nothing in the UI though! And I did try restarting and searching again - no dice. And I did move all my Sonos’ to fixed IP.

The new app uses a new integration to add the devices, are you using that? What’s your Sonos model?
Tagging @BarryA resident expert on Sonos :slight_smile:

No, I am not using any integrations, but I am using the new app - I also tried the Classic app, no dice there either. On the new app, I tried two methods - scan nearby (which generates all those log messages) and also adding a Sonos speaker by choosing Sonos as brand. Neither is working. I have a number of Sonos models, but MOST of them are recent Play:1 models (non Alexa, not Sonos One)

@schwark, what version of the Hub do you have? This works only with v2, v3 or the WiFi Router thingy.

Have you got any of those? By looking at your forum registration date being from 2014, I guess you might have a v1 Hub.

Otherwise, you can try to power down the Sonos and power it up by unplugging and plugging back, when it powers on it starts to broadcast SSDP, if other things on the network does aggressive SSDP broadcast, the Sonos can go “quite”.

I do have a V2 hub - I did a painful migration from my v1 hub to the v2 hub many years ago when the v2 hub came out. I tried the plugging it in. The funny thing is as I mentioned in the post above, the logs seems to show the SSDP responses for all my Sonos Speakers. Not sure why they are not showing up in the app as items I could add.

Ok, try them one by one. Power the other ones down and go only with one first. And wait as much possible. If you haven’t migrated yet, you can try the same add device from Classic, might work.

To add any device, as my experience, it takes time to show up.

Any luck with this I have the same issue. I thinking because alexa and google working with them it has something to do with 2.4 and 5 networks. All my sonus are on 2.4 and smartthings is on 5. Classic app worked fine

I had the same problem. I could not connect the sonos after the migration to the new app whatever I tried. Today I manually connected them in the API-portal and now they are back in the new app.

Could you tell me how to do that manually? You created them manually and set DNI to their IP hexified? Also, what did you do for rooms that had multiple speakers paired - which one did you use the IP for?

I am also having this issue. My SONOS speakers cannot be discovered no matter what I do. My hub is a v2 hub. My speakers were working before the upgrade. Now they don’t. So I deleted them so I could reinstall them after the update. Now they cannot be rediscovered.

Same issue here. I noticed that announcements weren’t being made. Tried to remove and re-add that speaker to no avail; then noticed all my other speakers were offline.

Doing all of this from the new SmartThings app and the using web socket device handler. Originally migrated with no issue. All my speakers (13 of them) have reserved IPs and are otherwise working fine.

Any help is appreciated. Thanks!

I just clicked create a device. In the box device network id I just put in the ip-adress in plain text. For the type I choose Sonos. Added name and I tested it and it just worked.
If I knew it was this simple I would have done it a month ago when I lost the speakers from the app. I only have two sonos speakers yet and they are in different rooms so I don’t know how to connect paired speakers.

I tried this and still couldn’t get it to work. I tried the IP address for one of my players as well as the MAC address for the device network ID (DNI). My devices, when they worked, used the mac address as the DNI. I tried the “LAN Sonos Player Websocket,” “Lan Sonos Player,” and “Sonos player” device handlers and none work (although I believe we are supposed to be using the websocket handler as the other will be deprecated).

I can add the devices and they show as “online”, but nothing seems to work. It can’t read the current status (i.e., whether anything is playing), it cannot control my Sonos, and text to speech is not working. This is all from the new app.

I’ve been trying to fix this for three days now and at a loss. Like @schwark, I can see SmartThings detecting all of my Sonos players in the IDE log when I attempt to add a device, but nothing shows up in the app. Very frustrating because I widely used TTS notifications and none of that is working now.

Any other help/suggestions are greatly appreciated! Thanks!

Which device type did you use? Sonos Player or one of the LAN Sonos Players?

Hi everyone - Thanks for bringing this to our attention. We have identified an issue with our Sonos integration that may impact discovery, control and status updates of Sonos speakers for some users. Investigation is still ongoing, but it appears that there has been a firmware update to Sonos devices that changes the behavior of how we communicate with the devices via WebSockets. We’ve opened up an incident ticket with Sonos and will be working with them to resolve the issue.

From our initial investigation this issue may primarily affect users that have a large number (8+) of Sonos speakers added to a single Sonos household. Users with only a small number of speakers may not experience any disruption. Also, users that have a large number of Sonos favorites may not see the full list of favorites reflected in the device detail view in the SmartThings app.

If you are experiencing issues related to the above, please feel free to DM the following info:

  • Specific issue you are seeing (discovery, device control, status updates, etc)
  • How many Sonos speakers you have in your Sonos household
  • The build and version of your Sonos system. Can be found in the Sonos app via Settings gear -> System -> About My System.
  • Approximately when you first noticed issues with your Sonos devices in SmartThings.

Hang tight, we are working to get your Sonos speakers back up and running in SmartThings ASAP.



The only type I found in “Type”-list was “Sonos Player” so that what I used. I don´t know the difference between the types.