Sonos speakers not being discovered - New app!

Based on what @BarryA said above, I figured out a temporary workaround to get at least a few speakers added. I unplugged enough speakers to get down to 7 in my Sonos environment. I then scanned for new speakers in the SmartThings app.

The seven speakers appeared and I was able to add. Great success! I plugged all my speakers back in, and it still appears I have functionality in SmartThings (although I have not tested thoroughly).

I hope this info helps everyone out as Barry and Sonos sort out the issues with the integration.

When you turned all the speakers back on, did it add the other speakers, or were you only able to add the first seven?

Only the first seven. All speakers work in Sonos, but only the seven I added in SmartThings are useable in SmartThings.

I tried adding the other speakers after the initial seven, but they go undetected (same as before).

I mainly use one or two speakers for announcements, so this will tide me over for a bit until they fix the integration.

At the transition to the new app status update was the issue along with control. I removed all speakers from my account. Now discovery is the issue. The app does not find any and they are playing music currently. I have 13 speaker in the house. I’m going to unplug all but 7 of them and try discovering again and user above did. I also had and issue with a switch with discovery and was able to add it with the classic app.

Sonos app version 12.1.1
Sonos OS. S2
6 Play 1s
1 Beam
1 Play 3
1 Play 5
1 Playbase
3 Sonos One’s

Update

Unplugged all speaker’s. Rebooted ST and router. Plugged in one speaker at a time and ran add device in smartthing each time. All was good 7 for 7 then number 8 added but sows off line. Then adding device would not find any more of the 13 speakers. Grouping of speakers does not work in smartthings although other controls worked

Hey all - We have a fix rolling out to our beta users tomorrow and then to production shortly thereafter. If you are not enrolled in the hub firmware beta and would like to get the update tomorrow, send me a DM by 7AM CST tomorrow.

Thanks again for your patience while we work through this issue.

Barry

1 Like

Up and running again using the beta firmware! Thanks @BarryA for addressing this so quickly!

1 Like

The beta firmware works beautifully - thanks for a quick fix… Now the only issue is that WebCORE does not recognize these speakers as a speaker capability. Not sure if that is something WebCORE needs to fix or something that is different about these speakers on the SmartThings side.

EDIT: Sounds like they show up in Refreshable devices in Webcore not in speakers. I am not completely sure if they will play via Webcore, but they are now added to Webcore as well this way.

1 Like

I’m not very familiar with webCoRE, but for capabilities the old, unofficial “Labs” Sonos integration that we migrated away from used the now deprecated Music Player capability. I believe webCoRE may be filtering on that capability. The capabilities the Sonos Player Websocket DTH supports are the following:

		capability "Refresh"

		capability "Audio Mute"
		capability "Audio Notification"
		capability "Audio Track Data"
		capability "Audio Volume"

		capability "Media Group"
		capability "Media Playback"
		capability "Media Presets"
		capability "Media Track Control"

The above Media* and Audio* capabilities are intended to replace Music Player. It allows developers to create integrations for devices that may only have a subset of the functionality that the old Music Player capability required. I’ll admit the migration from the old to the new had its issues, and we tried out best to transition all the existing Sonos devices the best we could. If there is a way to have webCoRE filter on the the core Media capabilities that typically define a speaker, for example Media Playback and Media Track Control, that should provide a good list of speaker type devices.

Barry

1 Like