Sonoff SNZB-01 Button with beta Zigbee Button driver

The SNZB-01, which identifies as the eWeLink WB01 (for all mine) or the eWeLink SNZB-01P, has made its way from the Ikea Button DTH to the Zigbee Button driver and is in beta.

I’ve tried it on a couple of buttons and absolutely nothing is happening with button presses for me (nothing is logged for the presses). The battery reporting is working, though suspect (I’d be surprised if they are really still 100%).

Anyone else had any joy?


Thanks, I was aware there is a community solution but my interest is specifically in the stock driver. If it works for others then I will need to look again at what I am doing, but if it doesn’t then I can reasonably justify being a bit cross.

1 Like

I tried it. Works randomly. It notice push but not react on it every time. Changed back to the communitydriver.

im using the edge driver on all my snzb-01 's and there working great .

And that is the beta channel Zigbee Button driver that was updated on the 2nd August? Hmm, wonder what I am missing.

the RDG - Zigbee Button driver

Ah OK. That’s a relief.

OK, a question for those who know what they are talking about. The Sonoff button apparently uses the OnOff cluster for reporting button presses. In the DTH (Ikea Button) there is an explicit ‘add binding’ for this but I don’t see that in the Zigbee Button driver, though other sub-drivers that use OnOff seem to include it (except I couldn’t spot it for the IKEA buttons either). My superficial understanding says this is bad. I didn’t see any suggestion of a binding for OnOff in the logcat, just the battery (and that works).

@nayelyz The grumpy old bloke is struggling …

By the way, is it just me who wishes the logcat output would make the error levels occupy the same fixed width so the output lines up better vertically?

1 Like

oooh, I see what you mean. Yeah, the binding part is the most important, even if you send a configureReporting command, the device won’t report anything to the Hub.
I’ll create the report as it is, because there’s clearly a difference, if we need your help to get some info, we’ll let you know.

Looks like the fix is incoming

That will be welcome. Once the buttons are sorted I’ll only be left with my Sonoff S26R2ZB outlets on DTH rather than Edge. They are a bit crap still to be added to the Zigbee Switch. Then there is just the question of what will happen with the Sonos integration.

Also Hue. It still uses Groovy DTH. Both are in some kind of private repo, so harder to track.

More importantly what will happen to Samsung speakers currently using “LAN SamsungAudio” and “SamsungAudio”. I’m sure they’ve thought about it.

I hope the fix works because it is torture waiting for the driver to be updated.

1 Like

Hi, @orangebucket
Can you help us verify the update of the driver solved the issue, please?
The bind_request was included (here) and it’s now live.

My current driver version is still from 9th August but I’ll try deleting the devices and uninstalling and reinstalling the driver.

Nope, no new driver there yet.

Mmm are you in the Beta group? Just to check if you have the latest firmware (44.9).
Also, you could try using the command smartthings edge:drivers:install, then, select the driver from the beta channel to see if this pulls the latest update, we have seen that helps.

I have one hub in beta, though it missed out on the 44.x round of updates because I didn’t think to update centercode after creating a new Location with a different owner and so there was an inconsistency in the profile when the target list was created.

Ownership is something that needs addressing. Unless I am using an app as the Location owner I don’t see the ‘Driver’ info in the app and Edge based devices don’t onboard. I like it that way, but I don’t like the app failing silently and it is all a bit inconsistent.

I digress though. I’ll play with the CLI in the morning as by the time my laptop boots up I’ll probably be asleep.

All my beta channel drivers on both my hubs are the 9th August 19:25 versions so I just assumed a new build hadn’t happened yet.

The issue with the driver Info is already being handled by the engineering team, I’ll check the part of joining devices.

Ok, I’ll ask about this, so, you’re currently on version 43?