Sometimes lights turn off randomly

Hello all,

I have a couple GE smart switches that seem to turn off all by themselves at random times. All switches are 1-5 years old and I haven’t mad any new routines lately, either. I do, however, have quite a few devices to control the switches (Action Tiles, Google Home, phones, tablets, etc.) Where do I start troubleshooting?

good luck -jim

Yes this has bee happening to me and I just noticed it lastnight.

My Front Yard patio lights is set to turn On at Sunset and turn Off at Sunrise.
I noticed it would turn off at 1130 pm.
I got up in the middle of the night at 130am to get a drink of water and turned On the lights through the app…
The lights turned off again 146am

This is the 2nd time this week I noticed this.

Furthermore i noticed my smartlight settings are not turning On at the set Sunset. Turns On earlier

Noticed my porch light is turning ON at an earlier time than the specified 1055pm…
It would turn on at 1011pm

How can i troubleshoot this? Or is it the New App …doing something funny?

Thankyou in advance

@RC51TofuMan @guessrow happening to me too with my tasmota plugs…

Another reason to speed up my transition to hubitat

GE zwaveplus switch
Glad to know it’s NOT just me

What’s next?!?!

My wiring hasn’t changed, so I highly doubt it’s that. It could be a device failing or some old automation pushing it but I don’t know… If I know the signal to turn off came from the device (and nobody had touched it) I could presume the device was going bad. but if the signal came from a specific automation/routine I could work on fixing it. But where to look??

good luck -jim

1 Like

I logged into IDE and clicked Repair Zwave Network
I deleted my Light Automation (originally migrated from Classic app) and created a New Automation in the New App

Hopefully this works

Light turned “on” randomly for me this morning. Got blasted with the light of a thousand suns this morning while still in bed. :face_with_symbols_over_mouth:

SHM armed last night when things quieted down last night. This morning, Good Morning Routine activated when things started happening. Unfortunately, Smart Home Solurions is not working (loading in Classic App) and Good Morning Routine did not disarm SHM. So when the door opened, all the Lights went to 100%. Since I can’t load Smart Home Solutions, I now have an active Intrusion that Incant do nothing about. :face_with_symbols_over_mouth:


  1. I deleted my automation in Smart Lighting for my Front Yard Lights (turn On sunset Off at sunrise)
  2. I went into the Front Yard Light switch tab. It allows you to choose specific Time On / specific Time Off. Every day of the week setting.

It worked. Turned on at 8pm…i am awaiting this morning but assume it will Turn Off at 6am.

Through the night…the switch did not Spontaneously Turn On or Off…like previously posted.

I assume something “wonky” going on in the Smart Lighting Settings. Here is a couple of screen shots.

I will reprogram Smart Lighting Settings again…to turn ON at Sunset and OFF at Sunrise Today

Age old issue with SmartThings. ST will blame the device. Experience suggests it’s a ST issue.


It’s been happening to at least two of my z wave neo coolcam lights switches. They randomly switch themselves on and off. I’m quite sure it’s not an issue with the devices.

@neil1234 this probably confirms that it occurs with most smart things devices, not just a couple brands

Hi @RC51TofuMan - Did this work for you? Do you think it was the repair z wave network that fixed it or deleting the smart lighting automation?
I don’t use the smart lighting smart app so wondering whether my standard lighting automations may be causing the issue or whether it might just be fixed with a repair z wave network. Thanks

Hello Neil
I have been working on a number of issues.
This particular is no longer an issue
I did a number of things out of frustration.
I deleted and rewrote lighting automations in the New app
Repaired Zwave through IDE
Rebooted hub through IDE

So far I don’t have this issue anymore. My lighting is working correctly now.

I am working on my mobile presence now- keeping my fingers crossed. I think I have that resolved. So far it works…
Out of town and will return tomorrow.
Working on 1 of my zwave switches not turning On …on the 1st attempt.

Thanks @RC51TofuMan. I’ll try to reboot the hub through the IDE as well. Hope yours continues to all work well.

If it’s not thing it’s another right?

Or maybe I am asking for too much

I logged in and am unable to find “Repair Zwave Network”

yeah i think your right . ST maybe time to hang this app and device up.
sell it to amazon, so they can fix it…

Finally found out what was causing a handful of my lights to turn off at night: Alexa.
I didn’t have any routines for those lights in ST, so I checked the Alexa app. When I looked at one of the devices, it showed activity. Clicked on the activity to see a full history and low-and-behold at the time my lights were turning off was an activity that Alexa figured I might want the light to be off.

1 Like

Thank you Nick. We had the same problem and the cause was 100% Alexa.

The app had created an automatic routine to turn off all lights at midnight.

This ended up turning off all our outdoor lights as well, which was not desirable.

There was no debug info I could find until I saw your suggestion.

1 Like