Lights on, but showing as off in the app


(Bob Anderson) #1

I have my front porch lights set to turn on at sundown and off at sunup. I’m using two built-in smart apps to do that (which is really odd, but I hear there is a new UI coming so I’ll refrain from a long walkthrough of how counterintuitive that was to set up.)

Last night I took out my phone and looked at the “Lights and Switches” section which said “all lights are off”, which didn’t seem right. If I clicked on that, it takes me to a display which said my front porch lights are off. But physically, they were on (which was the correct behavior via the smart apps).

Any ideas of what can cause this kind of problem? My “things” section said the switch was connected.


(Tim Slagle) #2

Try a hub reboot. If that doesn’t work try deleting and readding the shortcut


(sidjohn1) #3

IDK if i’d jump directly to a hub reboot, cause it may or may not do anything for you. First the UI is not always accurate. I have played with both IOS and android apps and the android app does not seam to update as well as the IOS app does, i can’t comment on the windows version. Secondly what are you actually turning on, is it a light bulb or a switch and whatever you are turning on is it zwave, zigbee or wifi. Wifi devices can easily fall out of sync with smartthings, depending on how the devicetype is written. If you are using a smart bulb attached to a dumb switch and the dumb switch gets toggled the smart bulb may not reconnect to smartthings properly. This seams to be common for wemo and wink bulbs. Finally if this is a common occurrence try to keep live logging open around the time your lights are set to turn on/off it may give you some ideas on what is actually failing.


(Tim Slagle) #4

My android app is rarely inaccurate.

On the rare occasion it does happen, a reboot solves it instantly for me.


(Bob Anderson) #5

It’s a GE z-wave wall switch.

I just figured out how to go to the activity history for each device, so that might help in seeing what has occurred to get it “confused”.

Thanks!


(Jeff May) #6

Sometimes the galaxy Tab, I have to kill and restart SmartThings to get certain updates. It doesn’t freeze the entire app and I know it is the Tab because it will update on my phone correctly.


(Bob Anderson) #7

It happened again this evening (showing as off while actually on). I went to the activity log and noticed that it had stopped logging activity the day before, and did not show the timer based on that had occurred as the lights were definitely on.

I manually turned the switch off then back on, and this seemed to reset things. This appeared in the activity log, and the status switched to the correct status of “on”.

Will continue to monitor…


(Tim Slagle) #8

How far is your hub from this device? I’m thinking it may be a communication issue at this point.


(Bob Anderson) #9

It’s probably… 50 feet straight line distance, but that line passes through a couple walls and a floor. At first I discounted this because the light was responding to the smart app without fail, but maybe the issue is not the signals getting from hub to switch, but from switch back to hub with the status updates.

Maybe I need more devices in-between to bolster the mesh network. I’m sure I can think of something. :smile:


(sidjohn1) #10

@anderson110 Check out page 4 of the attached doc. i think your switch should be getting closer to 30ft than 50ft consistently. Sounds like you are 1 wave plugin/wirein device from automation bliss :wink:
http://ecx.images-amazon.com/images/I/71W948wFilS.pdf


(Tim Slagle) #11

As i add more devices my network gets more and more consistent and reliable. More devices=better mesh