Something is triggering at 22:30 each evening

Something has started triggering my presence at 22:30 each day and I have no idea what it is. I’ve looked at the history in the SmartThings app and I just see the devices turning off or on. I’ve checked all the routines and nothing is set at 22:30

What could be causing this and is there any way I can locate the problem?

I’d open a case with support. They can get detailed logs from your hub to help figure it out.

Thank you. I’ll ask.

Do you mean triggering the presence of a device running the smartthings app? Because I thought you were looking for other alternatives for presence. :thinking:

I’m now using presence of 2 iPhones to trigger virtual switches using vEdge to turn my Blink alarm on and off.

It all works well so far but at 22:30 something is turning the blink off it’s it’s on or on if it’s off.

For the life of me I can’t find out what’s causing it.

Are you looking at the device history or the more general app history? The latter (menu, history) will give you a broader view of scenes and routines firing and might help trace the origin - see screen cap below. If there’s no obvious trigger there, if you use Alexa devices, have you checked if hunches are enabled? You can check the activity history there too for additional clues.

My mother in law had this problem and needed to delete a device and readd it. What is a “Hunch”?

It’s when your Echo device starts doing things based on it’s understanding of what you might want. Examples below (Alexa, settings, hunches - in the Alexa preferences section of the menu)


No Alexa here. Just automations I’ve set up in ST and they run via IFTTT. Again nothing in IFTTT set to trigger at 22:30. I just can’t track down what the cause is.

Thanks! This was probably the culprit… I hope!

1 Like

Do you have Scheduling enabled on your Blink sync module? Although when you say “turning the blink off it’s it’s on or on if it’s off” that is something Blink doesn’t do.

Do you happen to have any Smart Lighting things set up that could be using those virtual switches?

No to both. It’s add that 4 things happen.

3 Blink devices change state
My mobile’s presence changes state (this is what causes the 3 blinks to change state).

Grrrrr. 2230 and the phone at home (not mine this time) has just falsely changed to AWAY and the alarm system has just turned on.

It’s driving me nuts.

Whille you’re waiting for ST support to get back to you, it dawned on me that you should install the ST CLI and turn on logging for all the drivers. It may give you a clue about what is firing around that time that is triggering the change.

smartthings edge:drivers:logcat --hub-address=x.x.x.x --all

I wonder if it’s something I’ve created and deleted and it’s hasn’t deleted correctly?

Also noted that these 22:30 events do not appear in the ST notifications tab, only in the history tab.

Did you try enabling logging with the CLI last night?

No. It’s a bit over my head without reading up on what to do.

It’s actually pretty straight forward. Simply download the CLI binary from the link above. If you are on Windows, open a command window and type the command above. If you are on a Mac or Linux machine, open a terminal window and use the same command. If you don’t know your hub’s IP address, you can find it in the legacy IDE here.

@h0ckeysk8er thank you. I’ll try that over the weekend.