SOLVED: Unable to connect Intermatic CA3500 w/ Hub v2

I’m new to Smartthings platform. Just bought a hub v2. I’m coming from a Vera 3. I have a couple of GE zwave outlets and a few Intermatic CA3500 zwave outlets. I had no problems as far as getting these devices to work with the Vera 3. But the UI got old and is not very user friendly for my wife and kids.

I’ve already unpaired the GE outlets from the Vera 3 and are now paired with my hub. They’re working fine. I tried to do the same for the Intermatic CA3500. I’ve successfully unpaired them from the Vera 3 (I think). When I tried to pair them with my hub (by pressing the button a few times, and also tried holding the button for a few seconds), it wouldn’t pair. I searched the threads here and it looks like others have been able to use the CA3500 with their hub. Granted, the threads that I’ve seen were fairly old. I have not seen recent conversations about success/fails of pairing the CA3500.

Thanks for any help.

Try this first:

Then try to include.

Yup, I’ve already tried this. I received confirmation from my Vera 3 unit that it has successfully unpaired my CA3500 and GE outlets performing the same exercise for all units.

I was successful in adding my 2 GE outlets in my hub v2, but not so w/ the CA3500. I’ve tried multiple button presses on the CA3500…and even holding the button for a few seconds.

I’ve tried to re-add one of my CA3500’s back to the Vera 3 as a sanity check…and yes…I can add it back and unpair it again.

*** UPDATE ***
Got it working!!! After unpairing the CA3500, apparently I also had to go thru the exclude exercise as noted in the link you provided with the hub v2 first. After doing so, I was able to pair the CA3500’s to my hub! Funny thing is that I was able to pair the GE outlets w/o having to go through the exclude exercise. Right after unpairing the GE’s from the Vera 3, I was able to add them immediately in the hub. All is good now.

Thank you so much for the help @sidjohn1 !