Intermatc ca5100 not working for 3way


(Coolcatiger) #1

The GE 3way switch kit is not usable for me as I have 3 way switch with some non standard wiring .

So I came up with idea of using CA5100 accesory control. I installed a GE zwave switch in main outlet and Intermatc ca5100 accesory control in other outlet,
CA5100 just needs power and neutral to operate. I configured ca5100 as a z-wave switch in ST. It was fairly easy and quick to pair ca5100 with ST.

Then I install big switch app to operate GE switch when CA5100 is operated to make it work like 3-way setup. Looks perfect solution on the paper.
Eventhough linked to ST perfectly the CA5100 is not tiggering the “Big Switch” app to operate main GE switch to which load is connected.

I tried to change device type of CA5100 in ide to other z-wave device type. No luck with any of those.
Sent email to ST support 2 weeks ago, no response either. They were quick to reply before , but dont know what is going on now that they are taking long time.

Any help is appriciated!


(Solardave1) #2

I and a problem with a three-way once… Oh, wait, you’re talking about light switches. Sorry, wring forum.


(Jay) #3

when turning the CA5100 on or off, does the ST app show the new state immediately?


(Chrisb) #4

@surajt

How does the CA5100 show up in SmartThings when first added? Does it show up as a switch or as a Z-wave controller?

If it’s a Z-wave controller, then your out of luck right now. Secondary controllers are no usable with SmartThings right now. You may be able to find a way to tie it directly to the other z-wave switch but I don’t know how or if that’s even possible without having a separate main controller (like Vera, etc.)

If it’s showing up as a switch, but not working there’s one possible reason. Without getting far into the details some companies don’t pay a royalty to Lutron to use a stupid patent that never should have been granted. This prevents these switches from reporting to SmartThings (or any Hub) when you physically press the button. Intermatic is one of these companies. If your device is communicating with the hub via the mesh network, then it won’t report to ST immediately if you push it.

To test this press the button and look at the app on your phone. See if it reports that it’s been turned on. Wait for 20-30 seconds. If it doesn’t report that it’s been turned on within that time, try opening the settings and hitting refresh. If it reports now that it’s been turned on and see if the app fires now.

Let me know what you find out.


(Coolcatiger) #5

@Jay
No it does not. When I press app button for CA5100 I think events go through hub, I thought that would at least trigger “Big Switch” app. But it doesnt either.


(Chrisb) #6

Got another idea here…

The Big switch is a one to many relationship. If you turn on/off one switch, any others that you tied into the program will turn on or off with it. But it isn’t a true three way in the sense that if you turn on or off one of the related switches, it won’t change the state of the primary switch.

For example: Switch A is the primary, Switch B is the secondary.

If I turn on switch A, then switch B will turn on. Now both switches are on.
If I turn off A, then B will turn off. Now both switches are off.

But if I turn on B at this point, B will turn on, but A will still be off.
If I go to switch A and press that off, nothing will happen. A was already off, so no change. B still stay on.
Likewise, if A is on but B is off, pressing A on again won’t do anything.

So, if you’re using the Big Switch and you use this CA5100 as switch B in my example, it’ll never effect A.
Or, if you use the CA5100 as A, there are times it won’t effect B because A and B aren’t always in sync with each other.

I’d suggest getting my program: Wireless 3-way. It’s listed in the shared apps. This program will “bind” two or more switches together so that when any one of the group is turned on they all go on. If any one of the group is turned off, they all go off. It’s a many-to-many relationship. Any switch is always effect the other switches and they will never be out of sync.


(Coolcatiger) #7

@chrisb
Thanks, I installed your Wireless 3-way app. In ide simulator I created app with GE and CA5100. When I press GE switch I see events firing and icons status changing. But when I press CA5100 in simulator it does not fire any events and no change of icons status.

When linked ca5100 it showed as z-wave device on ST. I changed the device type to z-wave switch.

Btw Can I use another GE switch and just connect power , neutral and no load and use that as an 2nd switch in your Wireless 3-way app?


(Chrisb) #8

@surajt

Yes, absolutely. This is how I’m running two different setups. A 45609 in both locations one is wired to line, neutral, and load (lights), the other just to line and neutral. Tied together with the 3-way program and they work beautifully. Usually less than a 1/2 second of delay when I hit the “fake” switch before the main switch responds.

Now, having said this, there is one potential major pit fall: distance from hub. I mentioned this briefly in an earlier post, but to elaborate a little: GE (as well as Intermatic and Evolve) switches do not use the patent that Lutron has and therefore can NOT report to the hub that the switch has been pressed.

SmartThings uses a little trick to get around this partially. Basically the switch just sends a generic node command and SmartThings figures this may be because the switch was switched, so does an immediate poll of the switch, determines it’s current state and updates it as on or off. Works great for many operations, but it fails in three ways:

First, when a dimmer is turned off this does work. (The poll command is too fast and reports as still on as the dim fads to off).
Second, when an aux switch in a wired three-way setup is press, it never sends the node command
Third, if the switch does not have direct communication to the hub, the command isn’t received. The mesh network doesn’t pass on this node command to the hub.

So… long story short: If you’re using a dimmer on either side of the wireless three-way things will operate a little weird and won’t always work the way you expect them too.

If either of the switches is too far from the hub that it can’t communicate directly with it, then things will operate a little weird and won’t always work the way you expect them too.


(Solardave1) #9

Personally, I liked the road my 3 way comment was heading…
Just sayin…


(Coolcatiger) #10

@chrisb

To test this press the button and look at the app on your phone. See if it reports that it’s been turned on. Wait for 20-30 seconds. If it doesn’t report that it’s been turned on within that time, try opening the settings and hitting refresh. If it reports now that it’s been turned on and see if the app fires now.

When I press CA5100 button, I see the events flowing in app and ide for ON and OFF as below

zw device: 20, command: 2001, payload: FF zw device: 20, command: 2001, payload: FF false false

zw device: 20, command: 2001, payload: 00 zw device: 20, command: 2001, payload: 00 false false

but niether the app status get updated nor the 3waywireless app triggers on/off.


(Chrisb) #11

Hm… I really don’t know then.

Just to double check, did you uninstall the Big Switch app? Just want to make sure that it isn’t messing things up.

After installing my 3-way app, when you press the other button, does it turn on this CA5100?

Chris


(Chrisb) #12

Okay, one more thing: You said you have “non-standard” wiring at this location. Do you know for sure that you have a properly line incoming? That is a wiring that is always hot? Is it possible that the “hot” line you are using is only hot when the other switch is turned on?

Probably it’s likely, but I’m grasping at straws here a little bit. I can’t figure out why it wouldn’t work otherwise.


(Coolcatiger) #13

It’s always live wire. Big Switch is uninstalled. Other button does not turn on ca5100. 1st issue is the app does not get updated with ca5100’s status. I think it’s probably some thing to do with ST hub.


(Chrisb) #14

I’m quickly running out of ideas. Just for the fun it, do you have two other switches installed that you can run the 3-way program on? I’d just be curious if it works on those switches. If so, we can rule out an issue with software and probably the Hub as well.

You may also try resetting the hub if you suspect that’s the issue. Just unplug it for 10-15 seconds, then plug back in.


(Duncan) #15

Those events are Basic Set commands, like the CA5100 is trying to turn the hub on and off as if it were a switch. Our Z-Wave switch device type handler (and thus the Big Switch SmartApp) looks for Basic Report, which is how a normal switch tells us its state.

We’ll probably have to create a new device type for this controller switch. You can try it if you want, start with the Z-Wave switch device type handler and change the part that responds to BasicReport to respond to BasicSet instead.


(Chrisb) #16

Is this thing acting like a secondary controller then?


(Coolcatiger) #17

@chris - yes
@duncan - I am trying to create my device type and selected

  1. Capabilities = Switch

Not sure what to enter for

Custom:
Add Attribute
Add Command

Join Fingerprints:
EndPoint ? Profile ? Device ? Version ? In Clusters ? Out Clusters ? None clusters


(Duncan) #18

chris: It’s not actually a Z-Wave controller as far as I can tell. It just sends basic on/off commands.

coolcatiger: You only need the switch capability for Big Switch. You don’t need to add any custom attributes or commands. I wouldn’t bother with the fingerprint, just edit your device to change the device type.


(Chrisb) #19

@surajt

If you’ve written a SmartApp, it follows a similar setup. Be sure to give it a name at the top, then much of the rest of that stuff is optional (just like a SmartApp). After you’ve created the device you then get the code area (just like an app) and then you can browse sample code (just like an app) and overwrite your stuff with the sample code.

I haven’t really done this myself, just looked at it. I’m guessing you’d grab z-wave switch as your starting point… Then I’m not so sure what to do. I see this section:

def zwaveEvent(physicalgraph.zwave.commands.basicv1.BasicReport cmd) {
	[name: "switch", value: cmd.value ? "on" : "off", type: "physical"]
}

I don’t know if it’s as simple as just changing that to .BasicSet… (I’m guessing not.)


(Coolcatiger) #20

I dont see any option to copy setting from exsting device and create your new one.