So I Screwed up. I removed my hub before removing my devices

So a few days ago, my Smartthings hub (v3), started doing something weird, rebooting frequently, for about an hour. It finally stopped, but my devices stopped working. I was able to reconnect most of them, but in haste, i was like ‘hey why don’t i just reset everything and start from scratch’. Well that ended up being a disastrous move. To spare the boring details. Here is where i am. I can reconnect the Smartthing devices, however any third party (Zwave/Zigbee), i can’t hard reset them, nor re-add them to the smartthings, it sometimes says ‘Couldn’t verify QR code’ or ‘Couldn’t add device. Your hub doesn’t support this device’.

Some of these devices are all over the map if you were wondering. Stelpro, livingwise, GE and a few others i cant remember. All in all, all these third parties, are just not hard resetting. Which is frustrating, and in hopes/fluke i can re-add them, it gives me the above errors, or just unable to find devices to pair.

So help? I’ve been using this setup for about 4 years now, and its amazing how lost one can be when you had a lot of things automated! (its not that bad, but man you forget how convenient you made things to be)

For context, i have logged in here:
graph-na04-useast2.api.smartthings.com
Can’t seem to find anything wrong. Would love to add things manually here, but I wouldn’t know where to begin! However if I am unable to reset the devices in question, its a moot point.

I’ve tried contacting support, but I got scripted responses, that lead no where, and it was frustrating talking to half a robot.

For z-wave devices, try excluding them. To do this, in the ST app, open the hub and click on the 3 dots in the upper right, tap z-wave utilities and select z-wave exclusion. After excluding them, then try adding them.

For zigbee devices, for battery power devices, you should be able to remove the battery in most cases but some may require a button press depending on what it is. If you have any zigbee bulbs, let us know the brand/model.

If you still have issues… provide us with more details. Brand/model for devices you can’t add back. Are you able to add any devices?

Stelpro STZW402+ - Thermostat (doesnt hardreset, doesnt show menu 7 in advanced, shows its still connected?!?!) - Zwave
Livingwise Smart outlet - Zigbee
GE in Wall smart fan control ZW4002 - Zigbee
Zooz on/off wall switch ZEN26 - Zwave
Sengled lightbulb E11-G13 - Zigbee

So the devices above, will not hard reset.
Nothing shows up in the exclusion.

Try moving the hub near the devices. Depending on whether you are using wifi or not. Long ethernet cable :slight_smile:

Its kind of the opposite problem, the above devices, don’t even flinch when im trying to do a hard reset. They are not in my app right now.

What did you do … delete the hub? Reset the hub? Delete your location? Other?

When you login to IDE at the link you posted above… if you go to My hubs… does your hub show there?

So what i did was, delete my hub. Reset it, then added it back to my smartthings app. Then started the process of adding all my devices back. Then i ran into a hiccup of trying to add the other devices back that were non smartthings branded. i tried doing hard resets to those devices i listed, but none of them would hard reset, no signs of wanting to reset. This is where i am right now. I have a feeling i just screwed myself, and these devices are just useless now.

Assuming the hub itself is working, you should be able to recover, but you are going to have to be patient and just take it one device at a time.

When you reset the hub, it’s as if you went out and bought a whole new hub. Your devices still think they belong to the “old hub“, which is why they are not talking to the “new one.“ To them, it is though your next-door neighbor got a new hub. They don’t think it has anything to do with them.

So, one at a time, you have to clear out the old network information from each device, which will then get it ready to be added to a “new“ Network. Then you can add it just like it was a brand new device.

There’s no question that this will be tedious, but it should be doable. You are going to have to find the user manual for each individual device to find out exactly how to clear out that old networking information. It will be different for different models.

So the process is going to be

  1. pick a device to work on

  2. find the user manual for that device online. If it is a zwave device, look for the instructions on how to “exclude“ it. If it is a Zigbee device, look for the instructions on how to reset it.

  3. follow the instructions for clearing out the old network information. If it is zwave device this will involve doing something with your hub as well.

  4. once the device is reset, go back to the user manual and find out how to add it to a new network and follow those instructions

So… A lot of work, but you should be able to recover the devices, again as long as the hub itself is working.

Appreciate the insights you both are giving here.

So i had some Ah ha moments thanks to jkp, which was exclusion part (i didnt get at it first, but then figured it out), so it seems i have successfully got the Zooz and GE to be excluded, BUT… they wont reconnect. they wont hard reset either.

I feel like i am fight a losing battle.

IT WORKS!

Alright, so i’ll admit, its a bit of stupidity on my part, also smartthings glitching, and the devices not playing nice for hard resets.

I can’t say there was one clear answer here, but, its just persistence and keep trying. And trying different things.

Thank you for responding!

1 Like

This qlitch you mentioned is the same some of us has been experiencing. It could be fixed with reboot but usually power cycling is needed. And it probably will happen again and again until proper fix has been found.

Glad to hear things are working again! :tada:

One small note: “hard reset” is a concept that doesn’t really apply to most mesh network devices, particularly zwave.

These devices store two different type of information for themselves:

a) Information about the network they belong to

b) user-settable parameters. These might be anything from dim rate to whether a rocker switch turns off from the top or bottom of the switch. For a multisensor, there might be dozens of settable parameters. It just varies from model to model.

In a zwave context, most manufacturers use the term “reset” to mean “put all the user-settable parameters back to their factory defaults.” But it does NOT mean change the network information. The device will still be communicating with the same network. The assumption is that for professionally-installed Zwave devices (which was over half the market just two years ago), the end user gets to play with the parameters, but only the network technician should change the network settings. So two different utilities. :thinking:

To clear the network information, you do an “exclude,” not a “reset.”

So if you’ve been following instructions in the user manuals for Zwave devices, it’s very likely that a section on “how to reset the device” does NOT include preparing it to join a new network. That would be in a separate section on “network operations.”

Also, I don’t know of any zwave device that will clear its network information just from physical manipulation of the device itself, even pressing a “reset” button. Those are just for clearing the user-settable parameters.

Clearing the network information requires an exclusion command from a zwave hub as well as typically some physical manipulation of the device so it will accept that network command. Again, this was to protect the end user from changing the network settings unintentionally.

Like I said, a small point, but understanding this might help prevent some future frustration.