SmartTiles: Video Camera Compatibility

dashboard
smarttiles.click
smarttiles
cameras
project_cameras

(Ray) #403

Not sure what kind of video format ispyconnect is using for Web access but I think they are using subscription base and way more expensive for multi cameras so if you are going this route then I suggest going with blue Iris instead. You can wait a bit going and maybe Smarttiles V6 will support direct RTSP @tgauchat? There is also VLC to play around as well. I was using it to test my RTSP cameras but not running it as a server so I don’t know much of it. You can google it.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #404

Currently we can only support cameras whose feed can be embedded in the browser with no plug-ins. Browsers don’t support RTSP directly.

It’s a shame cameras don’t all have MJPEG, but transcoding services exist, even as a subscription service… (like iSpy…).


(Võ Thanh Minh) #405

Hi all, there is convertion software to switch from RTSP to HTTP? :sunglasses:


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #406

VLC perhaps? It would be fun to try…


#407

@tgauchat @625alex I have a nest cam but I can’t seem to make it integrate with smarttiles. I am running it on a browser with flash support and the url itself works but not in smarttiles. I then tried stop motion and it says “access denied” however, my camera is public. What should I do?

I just get a white screen where there should be the camera.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #408

We have to leave this question to the members of the Community in this Topic, as we don’t have cameras to test or debug with.

All our energy is on getting the next generation of SmartTiles working, and then some considerable focus will be on defining better support for video.


#409

@tgauchat Found the problem, your website is outdated:

For static images USE: https://nexusapi-ire.camera.home.nest.com/get_image?width=1280&uuid=
NOT: https://nexusapi.camera.home.nest.com/get_image?width=1280&uuid=


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy; NOT a SmartThings Employee.) #410

Thanks, Cell…

“-ire” suffix seems to imply that perhaps Nest has different services for different geographic regions (IRE would be Google / Nest’s Ireland data center; I’m guessing) … just like SmartThings has different addresses for it’s current 4 shards (NA01, NA02, EU01, AP01).

But I’ll update our website regardless and hope it helps some folks.


(Derek) #411

Gave this a shot, but the tile just remains grey when using a dropcam tile. I can however view the stream using the same http url in chrome just fine though.


#412

Copy everything starting with //video.nest from the embedded link then add https: in front of that. The instructions on the smart tiles site are dated. I just got mine working this morning. Mine is only showing at half the tile size for some reason. Hope to get that sorted out today.


(stephen) #413

What browser are you using?


#414

Does this still work? I have tried it on my Mac as well as my daughter’s Nexus. No dice. Just the blank tiles. I have also tried the direct browser link on Chrome using the configuration reflected. Still no luck.

I also have intermittent connectivity thru ST with the device handler. Anyone facing that as well?

Thanks!


(William Morris) #415

Still works. I haven’t updated my firmware since I got it setup–so it’s possible they’ve removed it since? What firmware are you running, I’ll check when I get home to see what I’m using.

Make sure you have the 2nd stream setup for MJPEG and at a bitrate low enough to fit your bandwidth.

I don’t have my amcrest camera in ST with any device handler. So I don’t know what to tell you about that.


#416

I have 2 cameras. 2nd stream is set up for both. Bitrate significantly lower.

Version is 1.11.1

Any thoughts would be helpful! Thanks…


(William Morris) #417

Looks like you might want to update then. I’m on 2.420 which appears to still be current. https://amcrest.com/firmware

Here are the streaming settings I use just in case.

And to be sure, I’ve only done this with the IP2M-841. No idea about the rest.


#418

OK - so I had originally given you the Amcrest Pro version from their other app. The web view app version and setup matches yours. Still no success with displaying the camera on smarttiles. Now I also get a message inweb view that says “resources are limited, failed to play video stream”.

Amcrest is driving me crazy!
What config did you use for the URL in smarttiles?

Thanks so much!!!


(William Morris) #419

http://user:password@ipaddress:port/axis-cgi/mjpg/video.cgi?subtype=1

I use that url twice.
Once for an MJPEG tile and for a website link tile that provides the video.
Second for a website link tile that I occasionally have to use for re-authorization.

Note that the link in that form does NOT work in browsers Edge or IE. It does work for me in Chrome, Firefox (after clicking a warning) and iOS Safari. Not sure about MacOS Safari.


(Devesh Batra) #420

anyone using the cheap Chinese made cameras in Smarttiles, like the Jooan one ?

they are down to $17 for 720p cameras on Amazon


(Faisal) #421

i am using cheap Chinese camera (ESCAM-QF001) and is working ok


(Faisal) #422

but this camera is RTSP so i use tinycampro app to convert feed to mjpeg and then it works with smarttiles. if u r buying new camera, its better to buy which supports mjpeg