Smart tiles vs DLink 5222L


#1

Hi, first time poster, long time lurker

Ok, got a DLink 5222L/B camera and want to show it in a smart tile (http://www.smarttiles.click/) great piece of kit.

But I just cannot get the correct URL for the video stream… I have tried in the smart tiles ‘Generic MJPEG video streams’

http://MYLANIPADDRESS/video/mjpg.cgi?profileid=1

http://MYLANIPADDRES/mjpg.cgi

http://MYLANIPADDRES:PORTNUMBER/video/mjpg.cgi

http://MYLANIPADDRES/video/mjpg.cgi

Anybody got any suggestions. greatly appreciated


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Are you able to see the stream when you use one of the URL formats in its own plain browser window / tab? That’s always the first test.


#3

Hi Terry, thanks for your reply

Yes… in a firefox tab I can see the video stream using http://192.168.0.3/video/mjpg.cgi

I bang that into smart tiles
By going to
’Generic MJPEG video streams’
then enter
’URL’
then
’Done’ four times

But the tile in smart tiles is still grey’d out

Am I missing something?


(Adrian Parker) #4

Hi @SteMac,

As Smarttiles is a cloud based service I believe you will need to enter the IP as your external IP address, not internal. If you’ve got a static IP or dynamic DNS service then this would be perfect. You will also need to forward ports on your firewall.

A quick Google of your router model will give you the info if you’re not sure how to do this.

Ade


#5

Hi Adrian, thanks for you suggestion

I can use a LAN IP and view it as a web page in Firefox
If I use a WAN IP I cannot view it in a web page (connection time out)… interesting…
The port has already been forwarded

I got the 5222L/B because it is officially supported by smart things and has been included
in the system, the 5222L/B stream can be viewed inside the app on android no problem there

I just cannot pass the stream onto smart tiles

hhhmmm interesting…


#6

OK, nailed it…

The only problem is, DLink will not allow a ‘no password’ set up
The 5222L/B when set up has to have a password to gain access to the camera

http://192.168.0.X/video/mjpg.cgi gets me to the camera log on page user = admin & password = password

This is where the problem is… smart tiles cannot get the stream because of the user/access log in

I tried to delete the user/password on the camera, but DLink’s software did not like it

Has anyone got a solution?

Thanks


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #7

I hope you find a workaround, but we are looking into improving / extended camera support for future versions of SmartTiles. We know it is one of the most loved features.

Whether or not we can handle login / authentication credentials for embedded streams is not something we’ve had time to research though.

There’s a task for you then? … See if there’s any discussions on the web regarding “embedding” DLink streams?


#8

Hi Terry, thanks for your help

But SmartTiles was not the problem, SmartTiles functions perfectly
Both you and alex have done a great job

It actually came down to the browser(s), which I found by accident
Withthe two tablets I was using, the browsers did not ask for the log on credentials of the camera!?
(They were both second hand)

Once it was put on a fairly new tablet up came the stream
I put Firefox for android on both the old tablets and the log on for the camera was
requested and bang the steam came straight on… happy days

To top it off my son wrote some css for the cobalt theme which fades the tiles in when activated
I’m the put it on the wall guy, he’s the mess about with the code guy

I often donate for software unless it’s a keeper and SmartTiles is a keeper

So, I ended up with this