SmartThings Wi-Fi wv525 won’t connect to modem

I’m trying to swap out my Xfinity provider modem router combo with a modem connected to my smartthings wifi.
Smartthings refuses to get an internet connection.

What I’ve tried:

  1. I’ve tried a couple different modem brands including the Motorola mb8600, aris sb6183, net gear cm700.
  2. Resetting the smartthings Wi-Fi - doesn’t get an ip and asks to manually enter details
  3. Connected to a router in the middle - this works but isn’t the setup I want.
  4. Tried bridge and auto mode

I’d guess that the ET-WV525 is in bridge mode. Use the Plume App and set the Network Mode to Router Only instead of Auto Mode and it should work connected directly to your modem.

I’ve tried setting to bridge mode and network mode. Same issue. With a hard reset I was hoping it’ll auto connect, but it keeps blinking green and red

Can you plug a computer into the modem to see what it is providing? I am unfamiliar with the Smartthings wifi device, but without knowing what is being provided by the upstream device it is very hard to troubleshoot.

What should I be looking for? Connecting to a laptop gives me internet access.

What is your local IP address? If it is a private address (192.168.x.x) that tells you the upstream device is providing dhcp, if it is a public address then the device is in a passthrough mode.

Then it’s just a matter of adjusting the config of the smartthings device to work with that configuration. Does the smartthings device act as a router/firewall?

That is a pretty simple device.

Make sure the cable from the xfinity box is plugged into the WAN port on the wv525. Fire up the plume app and make sure the Network Mode is set to Auto. Save the settings. Then power everything off.

Turn on the xfinity modem, wait for it to come online.

Turn on the wv525, wait for it to come online.

Is there a way to set the SmartThings configuration without connection? For a fully resetted hub it doesn’t show up on smartthings or plume app.

If the Wi-Fi hub is not detected, tap Add device on the dashboard. Then, tap under ADD DEVICE MANUALLY → Wi-Fi/Hub → SmartThings Wifi, and tap your Wi-Fi hub’s name.