Smartthings Smartcam RC8335Pro can't connect to my Wi-Fi Network

I used this camera for about a year and then it was unplugged and stored for a coupe months. Yesterday I plugged it back in expecting it to simply re-connect to the network and go…no such luck. I have reset the camera multiple times, Force Stopped the Smartthings app and cleared cache multiple times (Android) and turned off LTE data so only Wi-Fi data is available, and when my phone connects to the camera, gets an IP address (I assume from the camera) and then lists the networks to connect to, both my regular and guest networks are greyed out.

The only help available says that Wi-Fi is not strong enough (I am 7 feet from router) or that only WPA security is supported (my router ONLY supports 2 versions of WPA). I tried turning off the 5G also on the router and that did not work either. I have also re-booted my router. If I tap the i-info button beside my network name it says “Security Type = Other (not compatible)”

Any suggestions? Appreciate the help.