SmartThings camera won’t connect

hi all,

using this topic, any solution for smartthings camera to connect? Im stuck on the last page when is “regestering”


In the list of Smartthings items the app suports, cameras are no longer listed, or if they are i cant find them

No wait, i did stumble on a camera inclusion but unfortunately we dont seem to be able to see the supported devices

Did your install begin with a QR code or did you begin the install with a serial number ?

When onboarding, cameras cant be found using the obvious option

But can be found using partner devices

So if not already tried, try
Partner devices
At the bottom, the small blue text says
Cant find your device
Then add your serial number of the camera

Totaly illogical, convuluted and confusing

Another way to check if your camera is supported
Menu - at the bottom right of the app
Supported devices
Scroll to the bottom of the supported devices
Tap camera
There you will see a list of Smartthings cameras

1 Like

Hi Mike, thanks for the response, but it is the smartthings camera RC8335PRO, listed on the app. the problem is that I always get stuck on the registering page and never move foward. try with different wifi names, different phones, android also, and never pass trought that status. made lots os factory reset, everything that is possible and you can imagine, like adding by model, brand, type, qr code, serial number, etc :rofl:

If the device is listed as supported but continues to fail the on boarding process, then there are a couple of options left

The official Smartthings support route but that can be long and painful or if we ask @AlejandroPadilla if he has time, to look into the issue, it may be of interest as there may be issues with the new on boarding process which has recently appeared in the app

I appreciate it is frustrating but hopefully Alejandro will be able to help more in this circustance, especially as you have tried all ways to on board


i was trying to contact smartthings support, but the same awser as always “reset, try again and etc”

recently i made the app and ios update and try again, but same problem, doesnt connect. have the error print

i dont know how to fix it unfortunatly

looking foward with this error code, i tryed to change my ssid, remove the dashes or spaces, and everything possible.

@nayelyz please, any way to get help with this?

never pass the regitering page :confused:


Just a thought - have you checked with your vendor that this was not supplied originally under the Vodafone V-Home alarm program?